Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

SS3 sitetree ordering issues


Reply


7 Posts   836 Views

Avatar
ed89

Community Member, 4 Posts

31 July 2012 at 7:46am

Hi

We've recently been working with SS3 but are experiencing difficulty changing the order of the site tree using the drag/drop functionality.

If we drag one particular page from the top level, move it three below say, the message on the right hand side says that it has been reorganised successfully, and it appears in the correct position in the site tree, yet if you go to the front end it remains in its previous position in the menu/navigation.

I think this issue exists in 2.4 too, and saving and publishing the page again after moving it usually does the job, but doesn't appear to do it in SS3.

I've tried in all up to date versions of Chrome, Firefox and IE and it's the same in all three. It even happens on the SS3 demo itself, so I don't think it's something we might have configured incorrectly at our side.

Is anyone else experiencing this issue?

cheers

Avatar
gshegosh81

Community Member, 10 Posts

31 July 2012 at 9:07am

I can confirm that drag&drop reordering usually doesn't work without manually publishing in both 2.4 and 3.0.
In 2.4 when I reload everything, the moved page even gets marked with an orange color as not published.

Avatar
ed89

Community Member, 4 Posts

31 July 2012 at 7:58pm

Hi gshegosh81,

Yes, that's true of 2.4, but the same process doesn't seem to work in 3.0. The page remains where it was previously after moving it and manually publishing.

cheers

Avatar
ed89

Community Member, 4 Posts

6 August 2012 at 6:51am

So is no-one else having this issue? It's essential if we are to let our clients use SilverStripe but at the moment completely unusable!

Avatar
Schaper Software

Community Member, 3 Posts

25 August 2012 at 3:02am

Hi there,

I just have an even weirder effect here:
When I drag a Page to a new position in the Tree, after Save&Publish the Page jumps to another Position in the Tree (not the initial Position)

My solution was: Edit Tree with multiselect option, select all pages and batch action: publish.
After that, the page jumps to the place where I dragged it.

I think maybe the problem is has to do with an undefined position of another Page.

Avatar
Futureweb

Community Member, 233 Posts

26 August 2012 at 10:13pm

I've found issues here too - the expand arrow to show sub pages sometimes disappears, or even moves to the wrong page.

After drag drop moving, I tend to tick the 'multi selection' radio option, tick all the pages i've moved, and bulk publish them

It's was an issue in 2.4, and it would be really nice if it was fixed in 3.

Publishing isn't always ideal - there could be situations when a content editor has made changes and deliberately not published. So it would be much better in SS itself published the site tree order but not publish any content changes.

Avatar
Martin D.

Community Member, 21 Posts

27 September 2012 at 4:48am

The issue is still present with the latest 3.0.2. The only solution I found, as Futureweb writes, is to save/publish the modified pages.