Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Shortcode not working in jquery tools tabs [SOLVED!]


Reply


2 Posts   587 Views

Avatar
Pix

Community Member, 153 Posts

17 August 2012 at 1:26pm

I have a Shortcode which embeds a YouTube video. It works great everywhere except when I try and put it in a jquery tools tabs implementation I get nothing! I realize this is not much info to go on, but if anyone has any ideas at all I will be happy to post code and links.

I'm using SS 2.4.5 and when I paste the video embed code in the tab div ( as opposed to using the Shortcode) the video shows up fine. Heeeeelp I really want to make this work I would really appreciate any ideas or things to look into thanks!

Avatar
Pix

Community Member, 153 Posts

17 August 2012 at 2:51pm

Hi Folks,

OK this is SOLVED! First off, it's not a problem with the shortcode or SS for that matter! In a nutshell, the sample CSS I was using to style the tabs was whacked and hiding divs inside the tabs, so the video was actually there. It must have been some type of miracle to find this answer, I've been at it for two days and have lost much sanity. Anyway, the explanation and resolution is here if you are interested:

[url=https://github.com/jquerytools/jquerytools/issues/508]divs inside tab panes do not work[/url]