Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Search shows old results


Reply


3 Posts   394 Views

Avatar
jseth

Community Member, 98 Posts

1 September 2012 at 1:14am

I'm using silverstripe 2.4.4. I have a search feature included in the site. I have replaced a file with an updated one. When I do a search on the site, in the results I get the new file displayed, and also a result for the old file, which does not exist any more, resulting in a bad link being displayed. I have tried refreshing the browser which did not work in removing the bad result from the result list. I's just a simple $SearchForm in the header with a Page_results.ss text doc to display the results. I never noticed before if old results appeared, except for this time when I actually checked to see that the updated form would appear in the results. It does, but the old form link is still appearing also. Does anyone know how to resolve this? Thank you.

Avatar
Willr

Forum Moderator, 5513 Posts

2 September 2012 at 2:05pm

What search engine are you using? Sphinx, Lucene or just the out of the box full text search?

If you're using just the out of the box full text search version open up the Images section in the CMS and click the 'Look for new files' button in the top right. That will sync your filesystem and database.

Avatar
jseth

Community Member, 98 Posts

4 September 2012 at 11:41pm

Thank you! I am using "just the out of the box full text search". I did not know about the Look for New Files.