Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Media (Image) Upload Problem

Go to End

11 Posts   1487 Views


16 October 2012 at 4:35am Community Member, 22 Posts

Using a standard install of v3.0.2, when I upload an image into an RTE through the "media" icon it then proceeds to list EVERY image that I've uploaded since the last flush.

Clicking Insert proceeds to insert all the images, which is obviously not what I want, so I have to remove all items other than the one I uploaded.

Also, the alignment options are only available for the first image listed, which is never the most recently uploaded file as they display in chronological order. Which means after removing all of the unwanted images and inserting the correct one, I have to adjust the alignment by revisiting the media tab.

This happens even if I'm uploading the images to a different page.

Bug or feature? Any word on a planned fix / tidy?


16 October 2012 at 5:53am Forum Moderator, 1095 Posts

Hi feejin,

I ran into that same problem, and was wondering if this is by design for some reason , a bug or some caching issue? At least it doesn't try to upload those files again :-)

Did you spot an existing ticket for this behaviour?


16 October 2012 at 7:50am Community Member, 69 Posts

I ran into the same problem to. Mostly its not a problem, but sometimes annoying.


16 October 2012 at 9:16pm (Last edited: 16 October 2012 9:18pm), Community Member, 22 Posts

One of the SilverStripe devs replied to me on Twitter, it's a known bug with an open ticket:

It's been on critical priority since RC1 so hopefully will be done for 3.0.3.

For me, it's annoying. But not sure how I'm going to explain it to clients who maintain their own pages.


17 October 2012 at 9:10am Administrator, 685 Posts

Yeah - we're going to push to get this one resolved in 3.0.3.


17 October 2012 at 9:15am Administrator, 25 Posts

G'day Team,

Thanks for raising these issues. Sometimes it's not easy to tell what people are most interested in seeing fixed and we appreciate that you've all been open about it.

NOW...although the date has not yet been set for the 3.0.3 milestone, after talking to Sam, it's been moved into the milestone and will hopefully be assigned soon.

So. Anyone feel like having a crack at it? ;)


18 October 2012 at 4:55am Community Member, 22 Posts

Good news, thanks chaps! We tend to hand sites over to clients to maintain so bugs they're going to notice are the ones I like to see fixed :)


24 January 2013 at 10:41pm Community Member, 90 Posts

it looks like we still have this problem in 3.0.3. has it been fixed?

Go to Top