Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Performance SS3


Go to End
Reply


14 Posts   1944 Views

Avatar
hello_world

Community Member, 17 Posts

7 November 2012 at 4:18am

Edited: 07/11/2012 5:56am

Why silverstripe 3 i so very,very slow, just like road roller?
There is no comparison with eg. 2.4.7 . We have some large projects on 2.4.x and works fine.
But SilverStripe 3.0 work like diesel engine.
I am disappointed with the new generation Silver - everythings looks preety but that's not all.
I suggest create new forum "Performance".

Today we build small ecommerce solution - nothing special but I prefer not to think about how it will work on larger projects.
Are you also experiencing this?

Avatar
Willr

Forum Moderator, 5513 Posts

11 November 2012 at 4:28pm

SS3 has a rather unfortunate bug with the new config system. A patch for this is coming in 3.1.

Avatar
Johan

Community Member, 49 Posts

13 November 2012 at 11:29pm

Edited: 14/11/2012 6:07am

Hi Will

Will there be a patch in the mean time? Lots of server memory being used!!!

Thanks

Avatar
Guy Van Bael

Community Member, 35 Posts

18 January 2013 at 8:51pm

Since we use SS3 in production (already 5 websites), 3 out of 5 clients complain about pages loading very slow.
I also tested the latest 3.1 from githum, but hardly any performance improvement. Memory Limit on the hosting is 128MB, APC installed, gzip active AND using apc caching instead of file system....

Loading times from SS2.4 were a lot better... i really hope there's improvement on the way...

Avatar
Pix

Community Member, 153 Posts

24 January 2013 at 7:48pm

Same issue here. I'm glad I ran across this post as I thought I had something configured wrong. I finally took the dive into SS3 and used it on a recent site for a client. If anything, I expected the performance to be even better, but the site is much slower than a more complicated site running on the same server with SS 2.4.7 :0(

Avatar
boon

Community Member, 1 Post

27 January 2013 at 2:48pm

This CMS looked interesting, but I guess I gotta look somewhere else.

I see the latest version is 3.0.3. And this bug is supposed to be resolved in 3.1.
How can a bug causing slowness be treated as low priority?

Avatar
Willr

Forum Moderator, 5513 Posts

28 January 2013 at 10:24pm

3.1 is currently in beta and will be released as stable as soon as all the serious bugs have been ironed out. Give the beta a go and help report any issues.

Avatar
kinglozzer

Community Member, 171 Posts

30 January 2013 at 2:29am

Edited: 02/02/2013 12:14am

EDIT

Done some more profiling, results have been inconsistent so I think it's likely something on my site. Will profile both versions on a blank install in more detail when I get time.

Go to Top