Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

unable to add group / role - internal server error


Reply

5 Posts   505 Views

Avatar
Nachos

27 April 2013 at 11:35am (Last edited: 27 April 2013 5:31pm), Community Member, 18 Posts

Hello,

I created a website for my school with silverstripe 3.0. Now I'm configurating accounts for my colleagues but can't create a new group or role - when I click on the "add" button it comes an "internal server error". When I click on "add user" I can get to the form where I can fill the details, when I click on "save changes" I also get an "internal server error". This seems to work anyway, since when I reload the new user appears and I can log in with the given email and password. For roles and groups I don't get past the add button though.

Anybody has a hint what could be the problem? Would appreciate it!

Thanks for reading!

Avatar
Willr

3 May 2013 at 9:21pm Forum Moderator, 5511 Posts

Check your hosts php error logs for the actual error messaging (or turn on dev mode).

Avatar
Nachos

4 May 2013 at 2:22am Community Member, 18 Posts

Thanks for answering! I got this error in the log - it's the same error for all my problems with the security settings:

PHP Fatal error: Class 'Widget' not found in /.../blog/code/widgets/BlogManagementWidget.php on line 6, referer: http://mysite.com/admin/security/EditForm/field/Roles/item/new


Why are these settings refering to the blog widget?

Avatar
Willr

5 May 2013 at 4:22pm Forum Moderator, 5511 Posts

Try installing the widget module. Looks like it's missing and some of your code requires it.

Avatar
Nachos

5 May 2013 at 10:50pm Community Member, 18 Posts

That worked, thank you!

Pity there is no thanks button around here - I would use it!