Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

unable to add group / role - internal server error


Reply


5 Posts   575 Views

Avatar
Nachos

Community Member, 21 Posts

27 April 2013 at 11:35am

Edited: 27/04/2013 5:31pm

Hello,

I created a website for my school with silverstripe 3.0. Now I'm configurating accounts for my colleagues but can't create a new group or role - when I click on the "add" button it comes an "internal server error". When I click on "add user" I can get to the form where I can fill the details, when I click on "save changes" I also get an "internal server error". This seems to work anyway, since when I reload the new user appears and I can log in with the given email and password. For roles and groups I don't get past the add button though.

Anybody has a hint what could be the problem? Would appreciate it!

Thanks for reading!

Avatar
Willr

Forum Moderator, 5513 Posts

3 May 2013 at 9:21pm

Check your hosts php error logs for the actual error messaging (or turn on dev mode).

Avatar
Nachos

Community Member, 21 Posts

4 May 2013 at 2:22am

Thanks for answering! I got this error in the log - it's the same error for all my problems with the security settings:

PHP Fatal error: Class 'Widget' not found in /.../blog/code/widgets/BlogManagementWidget.php on line 6, referer: http://mysite.com/admin/security/EditForm/field/Roles/item/new


Why are these settings refering to the blog widget?

Avatar
Willr

Forum Moderator, 5513 Posts

5 May 2013 at 4:22pm

Try installing the widget module. Looks like it's missing and some of your code requires it.

Avatar
Nachos

Community Member, 21 Posts

5 May 2013 at 10:50pm

That worked, thank you!

Pity there is no thanks button around here - I would use it!