Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Help, can't install any modules. v3.0.5


Reply

4 Posts   479 Views

Avatar
jbryner

15 May 2013 at 5:47pm Community Member, 15 Posts

I'm upgrading a site from v2.4 to v3.0.5 I finally got the site up and running, but none of the modules I've installed seem to registering. For instance, I converted a gallery page to the Photo Gallery detailed in this page: http://www.silverstriperesources.com/articles/how-to-make-a-photo-gallery-in-silverstripe-3/ . I uploaded both of the "GridFieldBulkEditingTools" and "SortableGridField" folders to my site's root, with the other main SS files. But when I load up the gallery page I get a "Fatal error: Class 'GridFieldBulkEditingTools' not found " error. Neither of those modules show in the /dev/build output.

I also have uploadify and htmlpurifier, neither of those show up in the /dev/build.

Is there's something that I could've done in the upgrade process that would make these modules not install?

Avatar
Bambii7

17 May 2013 at 12:41pm Community Member, 254 Posts

Hi jbryner,
isn't the uploadify module a 2.4 extension (from the righteous uncle cheese) don't think that will be compatible with 3.x
Also I had some issue with blog modules, as I was downloading the master copies of the branches on Github. I managed to get the GridField & Sortable grid going, if you're still having issues with the modules I can upload the versions I have.

Avatar
SnowBoarder82

4 July 2013 at 10:22am Community Member, 52 Posts

Hi jbryner,

I seem to be having the same issue with installing the gallery module as you've described. Did you ever come to a solution on this one?

Avatar
SnowBoarder82

5 July 2013 at 3:35pm Community Member, 52 Posts

Hi jbryner and anyone else experiencing the same problem.

You can see the thread for the fix on the GridFieldBulkEditing tools error with the SS3 Gallery Module here:
[url]http://www.silverstripe.org/all-other-modules/show/20465?start=56[/url]