Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Server Upgrade Woes


Reply

38 Posts   3341 Views

Avatar
Ana

29 August 2013 at 8:09am Community Member, 7 Posts

Hi to all,

Only recently I've noticed my website had the same issue, not accessible via the main address (or main sub-site address). I've tried the work-around but it did not work. Have you guys manage to sort the issue just with the work-around provided?

Thanks!

Avatar
DrWebGuy

29 August 2013 at 8:44am Community Member, 16 Posts

See my previous comment. Check your root directory for any html or php files that the server could be looking at as an index file. (home.php, welcome.html, etc.)

Avatar
Ana

29 August 2013 at 9:40am Community Member, 7 Posts

Ah, worked like a charm! Thank you so much, @DrWebGuy!

Avatar
DigitalDesignAustralia

8 September 2013 at 3:54am Community Member, 2 Posts

I am having this same issue and getting mixed information from GoDaddy support. It's very frustrating.

I have applied the fix to main.php as provided (very helpfully) by GoDaddy in this thread which has helped in that most pages now work - with the exception that the homepage fails to load any content with the correct path (it continues to insert index.php/ before all content paths.

the site is two directories in (isolatedangles.com/clients/naomitroski)

The odd thing is that when clicking on links the first time from the homepage it appends the page url twice (http://isolatedangles.com/clients/naomitroski/clients/naomitroski/new-gallery-page/) but then clicking on the link again it calls the correct link (http://isolatedangles.com/clients/naomitroski/new-gallery-page/) ... Basically all links from the homepage are incorrect but off any other page they work fine..

Any ideas?

Avatar
Ana

8 September 2013 at 5:53am Community Member, 7 Posts

What fixed for me was to remove any HTML or PHP files from the root folder as the new version of Apache seems to get confused as to which file is the index file. It was suggested by DrWebGuy as an alternative to editing the main file.

Avatar
DigitalDesignAustralia

8 September 2013 at 12:14pm Community Member, 2 Posts

Thats solved it for me too now. Brilliant! Thanks very much. I still have the main file edited but deleting all php and html files from the directory including index.php has made it work. Thanks again.