Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Completely unable to login


Reply


6 Posts   416 Views

Avatar
Maex

Community Member, 4 Posts

7 July 2013 at 11:03pm

Edited: 07/07/2013 11:10pm

Hi guys,

I need some urgent help as I can't login into the backend anymore.

When I try calling my test.mydomain.de/admin I do only get an error 404
"The requested URL /admin was not found on this server."

As soon as I add ?flush=all I get prompted to the login mask.
There I have tried all different passwords and also all possible steps as described [url=http://www.silverstripe.org/general-questions/show/4717]here[/url] or [url=http://www.silverstripe.org/general-questions/show/5304]here[/url] but nothing worked for me so far.

When I check the tables Member & MemberPassword I can see that there is no login there.

Anybody an idea how to fix this and be able to login again?

Avatar
swaiba

Forum Moderator, 1798 Posts

7 July 2013 at 11:38pm

Only what is in those links...

Director::set_environment_type('dev');
Security::setDefaultAdmin('Admin','Admin');

Bottom line is if you have caused an error in your code that prevent the php from executing you'll never be able to login until you fix it

Avatar
Maex

Community Member, 4 Posts

8 July 2013 at 12:12am

When I do add the following two lines into the file mysite->_config.php

Director::set_environment_type('dev');
Security::setDefaultAdmin('Admin','Admin');


test.mydomain.de/?flush=all does not prompt me to the login mask anymore.

Any idea why or what else I could do?

Really have no idea how to fix this :(

Avatar
swaiba

Forum Moderator, 1798 Posts

8 July 2013 at 1:20am

test.mydomain.de/?flush=all does not prompt me to the login mask anymore.

exactly it removes the need to log in in order to make changes

I assume this is not a default, unmodified, clean version of silverstipe - in other words you have made changes to the code or added code. Those items that you have changed/added have caused the problem. Otherwise reinstall.

Any idea why or what else I could do? Really have no idea how to fix this

Neither do I or I would guess others here. Without FTP details to investigate it is almost impossible to tell as you. You also are very light on the details - e.g. is this a fresh install? has this been working until you did XYZ

Avatar
Maex

Community Member, 4 Posts

8 July 2013 at 4:24am

@Swaiba: You are right,I should have added bit more details to my first post so you better understand what I did do.

This version has not been modified beside that fact that I do have a customized theme.
I haven't tried to login since nearly 2 years but when I did try yesterday I apparently always typed in the wrong password.

So I search a bit on how to recover the password in Silverstripe and did find [url=http://www.silverstripe.org/general-questions/show/4717]this[/url] and [url=http://www.silverstripe.org/general-questions/show/5304]this[/url] posts in the forum.

I then did try all steps that have been described there but non of them worked.
So I went to myphpadmin and run the statement

DELETE FROM Member;

As also this didn't help I did some manuall changes in table Member and MemberPassword where I set email to admin and added a not encrypted password as I thought this will enable me again to login after calling test.mydomain.de/?flush=all .

Of course it didn't work and I have no idea how to fix this now?

What would you recommend?

Im using FileZilla and if you can tell me which details you need I will definitely post them here as well.

Thanks so much for your help!

Avatar
swaiba

Forum Moderator, 1798 Posts

8 July 2013 at 2:22pm

ok if it is a blank installation AND you know that you have tampered with the Member table I would so the following...

1)restore from a backup the member table (if possible)
or
2)upload a member table from my local host
or
3)backup the db and assests and theme - clean the whole site up and then use the db and assests and theme after you have reinstalled - EXCEPT filter the database to remove the member table

and please DO NOT post the FTP details here!