Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

PasswordEncrypter.php Error


Reply


5 Posts   436 Views

Avatar
Leon95

Community Member, 3 Posts

19 July 2013 at 6:44pm

Hello,
I'm searching and reading for a while, but it seems there is no solution for my problem.
I'm running SilverStripe on Microsoft Webmatrix and I had to change my admin password through the database.
After that an error appears:

[User Error] Uncaught PasswordEncryptor_NotFoundException: No implementation found for ""
POST /Security/LoginForm
Line 59 in C:\Documents\My Web Sites\Security FAQ\framework\security\PasswordEncryptor.php
Source

50    
51    /**
52     * @param String $algorithm
53     * @return PasswordEncryptor
54     * @throws PasswordEncryptor_NotFoundException
55     */
56    public static function create_for_algorithm($algorithm) {
57       $encryptors = self::get_encryptors();
58       if(!isset($encryptors[$algorithm])) {
59          throw new PasswordEncryptor_NotFoundException(
60             sprintf('No implementation found for "%s"', $algorithm)
61          );
62       }
63       
64       $class=key($encryptors[$algorithm]);
65       if(!class_exists($class)) {


Trace
PasswordEncryptor::create_for_algorithm()
Member.php:194
Member->checkPassword(<filtered>)
MemberAuthenticator.php:52
MemberAuthenticator::authenticate(Array,MemberLoginForm)
call_user_func_array(Array,Array)
MemberLoginForm.php:237
MemberLoginForm->performLogin(Array)
MemberLoginForm.php:128
MemberLoginForm->dologin(Array,MemberLoginForm,SS_HTTPRequest)
Form.php:363
Form->httpSubmission(SS_HTTPRequest)
RequestHandler.php:184
RequestHandler->handleRequest(SS_HTTPRequest,DataModel)
RequestHandler.php:204
RequestHandler->handleRequest(SS_HTTPRequest,DataModel)
Controller.php:153
Controller->handleRequest(SS_HTTPRequest,DataModel)
Director.php:307
Director::handleRequest(SS_HTTPRequest,Session,DataModel)
Director.php:119
Director::direct(Security/LoginForm,DataModel)
main.php:126

I hope you can help me and sorry for my bad English btw, I'm from Germany.

Greetings,
Leon.

Avatar
Devlin

Community Member, 217 Posts

19 July 2013 at 7:52pm

I had to change my admin password through the database.

Uhm, you do understand why this is a futile attempt?

To get you back in the CMS, add this to mysite/_config.php:

Security::setDefaultAdmin('123', '234');

Then go to 'mysite.com/admin', login with 123/234 and then give your administrative user a new password inside the CMS. After that you should remove the line from your config.

Avatar
Leon95

Community Member, 3 Posts

19 July 2013 at 8:30pm

Okay, I see... SilverStripe is really different from the CMS I use usually.

I now tried to add Security::setDefaultAdmin('123', '234'); to my _config.php but I'm getting the same error still.

Avatar
Devlin

Community Member, 217 Posts

19 July 2013 at 8:38pm

Edited: 19/07/2013 8:39pm

Did you tried to log-in with username: '123' and password: '234'?

Avatar
Leon95

Community Member, 3 Posts

19 July 2013 at 9:42pm

Of course, I understand the method, but now SilverStripe says:
"That doesn't seem to be the right e-mail address or password. Please try again."