Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Admin Access Error /Security/login?BackURL=%2Fadmin%2Fpages


Reply


2 Posts   498 Views

Avatar
Mr.T

Community Member, 1 Post

23 July 2013 at 11:35am

Edited: 23/07/2013 12:49pm

Hi All,

A bit of a back story.

We have a number of sites (4+) currently based on SS (3.0.2), whereby we have recently patched the server (to Apache 2.4).

Now anytime we try login to admin, it sends us back to xxx.com//Security/login?BackURL=%2Fadmin%2Fpages saying we are logged in as 'Default Admin' & just loops back to this page.

So far I have flushed everything, set Security::setDefaultAdmin('xyz','xxxxxxyyyyyyyyyzzzzz');, seemingly do not get any debugging info & studied the .htacess (nothing out of place, we have some authentication modules running), & googled the hell out of it.

It was the previous developer who chose SS (If I am honest Im not a big fan of it).

So where could my problems, potentially lie? We are using a slightly modified version of cloudy & blackcandy themes & the website is live, working other than the fact we cannot login to the backend.

I'm at my wits end with this, if we cant get it fixed, then it will have to be migrated.

Avatar
Willr

Forum Moderator, 5513 Posts

24 July 2013 at 8:09pm

Strange, as an admin you shouldn't be kicked back out of the CMS. Clear your cookies and after you have logged in, try going to /admin/ directly. It could be a number of things related to custom code you're struggling with so challenging to help remotely.