Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

silverstripe 3.1 performance time to first byte


Reply


4 Posts   622 Views

Avatar
Guy Van Bael

Community Member, 35 Posts

24 October 2013 at 4:02am

Hi,

Since 3.1 i'm comparing load times of pages and they are signifantly slower then page load times in 2.4.
All code in the templates is optimized, gzip compression on, minified css and js....

It's especiall the "time to first byte" that causes te waiting time... (an average of 3,5 second!).

Is there anybody here who can shine a light on this?

Thanks
Guy

Avatar
Bambii7

Community Member, 254 Posts

24 October 2013 at 3:00pm

Did you make a silverstripe-cache folder inside the project directory?
I know it was running slow for me until I made this folder.

Avatar
Guy Van Bael

Community Member, 35 Posts

25 October 2013 at 1:08am

Hi,

Solved it with partial caching the menu loop. Site had a rather large sitetree. Without the partial caching. Menu was recreated with every page load using php.

Partial caching solved it. We have normal loading times now.

guy

Avatar
tv

Community Member, 44 Posts

11 September 2014 at 1:48pm

Even with partial cache in place on 3.1, I'm still seeing First Byte Times 5 to 6 times what is recommended by Web Page Test.