Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Upload HTTP Error


Reply

4 Posts   317 Views

Avatar
Brendo

2 December 2013 at 4:57pm Community Member, 7 Posts

Hi,

I am fairly new to silverstripe but i can use it to manage the website content fairly competently, however i have run into an error that i am clueless as to how to get around.

I am trying to upload a Revit (Architectural Design Program) file to the Files & Image tab and then link some text on a page to that file however when uploading the file to the Files& Images tab it keeps appearing with 'HTTP error' and discontinuing the upload.

Has anyone encountered a similar problem and have a solution?

I should also mention that i have previously uploaded Images, PDF, Zips and DWGs without an issue.

I appreciate any help people could give me.

Brendon.

Avatar
martimiz

3 December 2013 at 10:40pm Forum Moderator, 1091 Posts

Dit you try putting your site in dev mode? That might give you the actual error.

Just in case - architectural design program kind of triggers this response: sometimes cad files can be small in size (far below 1Mb) but have hughe resolutions (say 4000 x 4000px or so). When GD loads these files in memory to create a thumbnail, your server memory runs out. SilverStripe only checks the filesize on import, not the resolution...

Martine

Avatar
Brendo

10 December 2013 at 4:51pm Community Member, 7 Posts

Update:

Problem partially solved. The file is uploading but not linking correctly.

The problem was that .rvt extension was not allowed. check thread below for answer.

This thread is helpful. http://www.silverstripe.org/general-questions/show/13686

im still having issues however. If you could point me in the right direction in regards to the problem linking the file i would be grateful.

http://www.silverstripe.org/customising-the-cms/show/28519

Avatar
Brendo

12 December 2013 at 3:05pm Community Member, 7 Posts

Solved.

Check this like too.

http://www.silverstripe.org/customising-the-cms/show/28519