Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Can't upload files


Reply

3 Posts   279 Views

Avatar
evjan

23 January 2014 at 12:36am (Last edited: 23 January 2014 2:44pm), Community Member, 7 Posts

Hi,

I have a 3.1.2 website and I can't upload images (png or jpg, or any file type for that matter) to it, I get a "Forbidden" message in a black popup on the top right.

When I go to the file manager in SS I can create folders and delete files, so it seems to be isolated to uploads only.

Also, it works like a charm when I try it locally on my dev machine.

Here's what I've tried:
- adding a 'upload_tmp_dir = "./tmp"' to php.ini
- setting permissions to /tmp and /assets to 0777 recursively

Any other ideas?

Avatar
Bambii7

23 January 2014 at 12:31pm Community Member, 254 Posts

sounds like you've tried the likely culprits. I did come across a Red Hat server that would get grumpy when files or folders were set to 0777, it wanted them as 644 or something. Might be worth a try.

Avatar
evjan

28 January 2014 at 11:25pm Community Member, 7 Posts

I tried setting it to 644 on tmp and assets and other combinations, but to no avail.

Any other ideas? It's weird that I have other SS sites on the same host (albeit running older versions of SS) and they work like a charm in this respect.