Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Can't build template for the home page


Go to End
Reply


12 Posts   2780 Views

Avatar
Uzenmi

Community Member, 19 Posts

24 December 2008 at 6:11pm

I did like this "http://doc.silverstripe.com/doku.php?id=tutorial:1-building-a-basic-site#using_a_different_template_for_the_home_page" but I do not understand the link "http://localhost:3000/db/build?flush=1" when I change to "http://mywebsite.com:3000/db/build?flush=1" its not success so I can not build template for the home page. Who can help me that?

Thanks very much!

Avatar
Liam

Community Member, 470 Posts

25 December 2008 at 5:28am

Need more information.

What errors do you get when rebuilding the database with /db/build?flush=1?

Might want to also post your code from the homepage php file.

Avatar
screpin

Community Member, 3 Posts

25 December 2008 at 8:28am

Hi!

I have the same problem. I installed SilverStripe today and I've been following the tutorial but I receive this error when I try to rebuild the database to create the new template called HomePage.ss:

Building Database

Creating database tables
# Newsletter
# Newsletter_SentRecipient
# Newsletter_Recipient
# NewsletterType
# PageComment
# Email_BounceRecord
# Email_BlackList
# PageView
# SiteTree
# Field SiteTree.ClassName: changed to enum('SiteTree','GhostPage','Page','UserDefinedForm','ErrorPage','RedirectorPage','VirtualPage','HomePage','SubscribeForm') character set utf8 collate utf8_general_ci default 'SiteTree' (from enum('SiteTree','GhostPage','Page','UserDefinedForm','ErrorPage','RedirectorPage','VirtualPage','SubscribeForm') character set utf8 collate utf8_general_ci default 'SiteTree')
# Field SiteTree_Live.ClassName: changed to enum('SiteTree','GhostPage','Page','UserDefinedForm','ErrorPage','RedirectorPage','VirtualPage','HomePage','SubscribeForm') character set utf8 collate utf8_general_ci default 'SiteTree' (from enum('SiteTree','GhostPage','Page','UserDefinedForm','ErrorPage','RedirectorPage','VirtualPage','SubscribeForm') character set utf8 collate utf8_general_ci default 'SiteTree')
# Field SiteTree_versions.ClassName: changed to enum('SiteTree','GhostPage','Page','UserDefinedForm','ErrorPage','RedirectorPage','VirtualPage','HomePage','SubscribeForm') character set utf8 collate utf8_general_ci default 'SiteTree' (from enum('SiteTree','GhostPage','Page','UserDefinedForm','ErrorPage','RedirectorPage','VirtualPage','SubscribeForm') character set utf8 collate utf8_general_ci default 'SiteTree')
# QueuedEmail
# File
# EditableCheckboxOption
# EditableDropdownOption
# EditableFormField
# EditableRadioOption
# SubmittedForm
# SubmittedFormField
# Group
# Member
# Member_UnsubscribeRecord
# Permission
# Widget
Error

The website server has not been able to respond to your request.

Thanks!
Sylvie

Avatar
screpin

Community Member, 3 Posts

25 December 2008 at 8:37am

Also, if I use http://localhost:3000/db/build?flush=1 like in the tutorial, I get a 404 Not Found Error.
So I tried : http://localhost:3000/SilverStripe-v2.2.3/db/build?flush=1 and I got the error I posted earlier!

Can someone help solve this problem?
Thanks!

Avatar
Uzenmi

Community Member, 19 Posts

26 December 2008 at 2:53am

Edited: 28/12/2008 6:08pm

I've done. Thanks

Avatar
Three Dog

Community Member, 6 Posts

6 January 2009 at 3:24am

Edited: 06/01/2009 3:43am

Have the same problem.
I Create a file HomePage.php in notepad and put this file in tutorial/code. Then I going to http://localhost/silverstripe/db/build?flush=1 and receive message:

Building Database

Creating database tables
# Newsletter
# Newsletter_SentRecipient
# Newsletter_Recipient
# NewsletterType
# PageComment
# Email_BounceRecord
# Email_BlackList
# PageView
# SiteTree
# QueuedEmail
# File
# EditableCheckboxOption
# EditableDropdownOption
# EditableFormField
# EditableRadioOption
# SubmittedForm
# SubmittedFormField
# Group
# Member
# Member_UnsubscribeRecord
# Permission
# Widget
# WidgetArea
# GhostPage
# Page
# UserDefinedForm
# ErrorPage
# RedirectorPage
# VirtualPage
# SubscribeForm
# Image
# Folder
# Image_Cached
# EditableCheckbox
# EditableCheckboxGroupField
# EditableDateField
# EditableDropdown
# EditableEmailField
# EditableFileField
# EditableFormHeading
# EditableMemberListField
# EditableRadioField
# EditableTextField
# SubmittedFileField
# Group_Unsecure

Creating database records
# Newsletter
# Newsletter_SentRecipient
# Newsletter_Recipient
# NewsletterType
# PageComment
# Email_BounceRecord
# Email_BlackList
# PageView
# SiteTree
# QueuedEmail
# File
# EditableCheckboxOption
# EditableDropdownOption
# EditableFormField
# EditableRadioOption
# SubmittedForm
# SubmittedFormField
# Group
# Member
# Member_UnsubscribeRecord
# Permission
# Widget
# WidgetArea
# GhostPage
# Page
# UserDefinedForm
# ErrorPage
# RedirectorPage
# VirtualPage
# SubscribeForm
# Image
# Folder
# Image_Cached
# EditableCheckbox
# EditableCheckboxGroupField
# EditableDateField
# EditableDropdown
# EditableEmailField
# EditableFileField
# EditableFormHeading
# EditableMemberListField
# EditableRadioField
# EditableTextField
# SubmittedFileField
# Group_Unsecure

But the is no HomePage page type in the list of page types under the “Behaviour” tab.
How solv it?

Avatar
Three Dog

Community Member, 6 Posts

7 January 2009 at 6:54am

Progress in tutorial completely stopped! Help!

Avatar
Sam

Administrator, 685 Posts

7 January 2009 at 5:32pm

Try putting your site into dev mode - http://doc.silverstripe.com/doku.php?id=debugging#dev_mode - and see if it gives you an error message.

Go to Top