Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

error Cannot write manifest file!


Reply

5 Posts   3088 Views

Avatar
pjssms

9 January 2009 at 1:02am Community Member, 49 Posts

Hello,

How do i fix this error ?

Everything was working ok before.

I have added some mutilingual funcionalities yesterday. What can this be ? What should i check ?

Warning: fopen(/tmp/silverstripe-cache-home-one100mp-public_html/manifest_home_one100mp_public_html_sapphire_main.php) [function.fopen]: failed to open stream: Permission denied in /home/one100mp/public_html/sapphire/core/ManifestBuilder.php on line 198
Cannot write manifest file! Check permissions of /tmp/silverstripe-cache-home-one100mp-public_html/manifest_home_one100mp_public_html_sapphire_main.php

Avatar
steve_nyhof

15 March 2009 at 10:29am Community Member, 224 Posts

I am running into the same issue. I didn't change anything, but now after I run the install, I get the same error. Someone please help!

Installing SilverStripe...
I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation

Creating 'mysite/_config.php'...
Creating /home/homering/public_html/mysite/_config.php
Creating '.htaccess' file...
Creating /home/homering/public_html/.htaccess
Building database schema...
Warning: fopen(/tmp/silverstripe-cache-home-homering-public_html/manifest_home_homering_public_html_sapphire_main.php) [function.fopen]: failed to open stream: Permission denied in /home/homering/public_html/sapphire/core/ManifestBuilder.php on line 198
Cannot write manifest file! Check permissions of /tmp/silverstripe-cache-home-homering-public_html/manifest_home_homering_public_html_sapphire_main.php

Avatar
Sam

15 March 2009 at 1:51pm Administrator, 685 Posts

Create a folder called "silverstripe-cache" along side sapphire, cms, jsparty, etc, and make sure that it can be written by your webserver.

Avatar
steve_nyhof

15 March 2009 at 2:54pm Community Member, 224 Posts

Thank you Sam!

That worked the first time. I was really bumming on this off and on all day. Thank you again!

Steve

Avatar
kcd

17 February 2010 at 8:47am Community Member, 54 Posts

Interestingly I got this error (or a blank page with a 500 Internal Server Error response) on two different windows machines (2003) with iis6.

I had to add security permissions for IUSR_[computer name] manually to get it to work. As soon as it worked once I then removed this addition and IIS would inherit the permissions as per normal. Strange.

This happened when I copied a newer version of my website over an old copy. All good now.