Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Tutorial 1 :: Doesn't Work


Go to End
Reply


10 Posts   2081 Views

Avatar
JasonS

Community Member, 14 Posts

28 January 2009 at 8:09am

Right, I have tried this twice now. I am using 2.3 RC2.

http://doc.silverstripe.org/doku.php?id=tutorial:1-building-a-basic-site

Creating a New Page Type.

I have created a new folder called 'code' in the tutorial template folder, added the HomePage and run the db flush. Nothing happens. Has 2.3 changed the way this works. Could someone tell me what I am doing wrong please.

Thanks

Jason

Avatar
UncleCheese

Forum Moderator, 4096 Posts

28 January 2009 at 8:24am

The code folder should be a peer to the templates folder, not its child. Can you post the code you're using?

Avatar
JasonS

Community Member, 14 Posts

28 January 2009 at 8:56am

OK, still confused. I am using the code from the tutorial.

/root/
/root/themes/
/root/themes/tutorial/

Where should the code folder be?

Avatar
JasonS

Community Member, 14 Posts

28 January 2009 at 9:09am

I should add that I did the tutorial install on xampp. I didn't install the the tutorial package. I already have 3 servers on my laptop. XAMPP/Rails/Django. Really do not need a 4th.

Avatar
JasonS

Community Member, 14 Posts

29 January 2009 at 2:51am

Can anyone help with this?

Avatar
UncleCheese

Forum Moderator, 4096 Posts

29 January 2009 at 7:01am

The code folder belongs in tutorial.. should already be there, though, right?

/tutorial/code/MyPage.php
/tutorial/templates/Page.ss
/tutorial/templates/Layout/MyPage.ss
/tutorial/css/css.css
/tutorial/javascript/js.js
/tutorial/images/img.jpg

Avatar
solar

10 Posts

29 January 2009 at 10:53am

Edited: 29/01/2009 10:56am

go to your "C:\xampp\htdocs\silverstripe\tutorial\code" folder and duplicate the page.php, if you copy pasted it (ctrl+c, ctrl+v) it will be renamed "Copy of Page.php" rename is to homepage.php then open the file in your editor...I use jEdit -=)

"class Page extends SiteTree" becomes -> "class HomePage extends SiteTree"
"class Page_Controller extends ContentController" becomes -> "class HomePage_Controller extends ContentController"

ok now go to your templates folder and make your HomePage.ss(just dup the Page.ss to HomePage.ss for how, then edit it after the flushes)

Flush your DB. "(mysite)/db/build?flush=1"
Flush your CMS "?flush=1"

when you login to the CMS under page type your going to see HomePage.

So if you want to know what you did? I got no idea
You dont have to name is HomePage you can name it any thing just as long as the php class names match.
Also the first time I tried this, during the DB flush I got some errors. I just did it over again and it worked.
Please tell me if this works so I can set up a tutorial -=)

Avatar
Sammy

Community Member, 4 Posts

10 February 2009 at 12:23pm

Doesn't work for me. The "change to HomePage" doesn't appear in the CMS. I have been trying to fix this for a almost a week with no success. Using Mac OS X 10.5, MAMP localhost:8888 and SilverStripe v 2.2.3.

Please help me!

/S

Go to Top