Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Setting Detailed User Permissions


Reply


5 Posts   1415 Views

Avatar
Twenty3design

Community Member, 7 Posts

29 January 2009 at 8:34am

Hi All,

I've seen similar posts for setting user group permissions but nothing which describes exactly what I'm looking for.

I'd like to set groups of users to only be able edit and create pages under one parent page, so essentially edit pages on their part of the site tree.
It would be great if in the security section of the CMS I could select a particular group and then select which part of the tree they can edit.

Any help would be greatly appreciated!

Thanks.

Avatar
Hamish

Community Member, 712 Posts

29 January 2009 at 8:57am

You should be able to do this from the 'access' tab.

You'll need to set all the 'parent' pages with restricted permissions, and make sure that all the other pages have 'inherit from parent page'. Then you can set which part of the site structure certain people can edit.

Avatar
Twenty3design

Community Member, 7 Posts

29 January 2009 at 9:14am

Brilliant!
So obvious, can't believe I didn't spot it, and thanks for the really quick response!

Avatar
Twenty3design

Community Member, 7 Posts

29 January 2009 at 9:34am

Help!?
Just trying to test this out and unfortunately the user permission settings don't seem to be working, only Full Admin Rights seems to work (which obviously doesn't help).
This is apparently the same problem a few other people have had, and the wiki isn't up to date:

http://doc.silverstripe.com/doku.php?id=permissions:codes

...is there some order I need to set these codes in or something like that?

Thanks.

Avatar
Twenty3design

Community Member, 7 Posts

30 January 2009 at 3:27am

I seem to have solved the problem, not entirely sure how it happened.
I simply set the group user Permissions to 'CMSmain in CMS', and THEN set the page to be editable only by that group, and now it works.

Thanks for your help :)