Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Unable to login to Silverstripe Admin


Reply

8 Posts   14463 Views

Avatar
Ricardo

12 February 2009 at 5:55am (Last edited: 12 February 2009 6:08am), Community Member, 11 Posts

I need some urgent assistance to get into admin panel as the passwords are not working.
I believe I have to make some adjustments but Iam not exactly sure

Ian

Avatar
Carbon Crayon

12 February 2009 at 6:53am Community Member, 598 Posts

Have you got into the admin area before or have you just finished installing?

Avatar
Ricardo

12 February 2009 at 6:41pm Community Member, 11 Posts

I was in log in admin area many times before using the default admin and password. I tried to change to my e-mail and a different password and I was unable to get back into admin. Each time i got a message saying it does not seem Iam using correct e-mail or password and try again when I use admin as email and password as password.

Thanks for your kind attention

Ricardo

Avatar
Fuzz10

12 February 2009 at 9:30pm (Last edited: 12 February 2009 9:30pm), Community Member, 787 Posts

Try putting a default username / password in your _config.php...

e.g. :

Security::setDefaultAdmin(’admin’,’password’);

Avatar
micahsheets

13 February 2009 at 9:48am Community Member, 164 Posts

I have run into a similar problem. I originally developed a site using _ss_environment.php on my development server. Now that the site is going live for a client I need to put the specifics of the live server in the _config.php and not use _ss_environment.php any more.

So I put all my config info into the _config.php file like I used to do before I could use _ss_environment.php and all works for the front end. However on the back end I can no longer log in using the admin credentials stored in the database. The login form tells me that the login is incorrect.

When I put Security::setDefaultAdmin('admin','password'); in the _config.php I can login.

My question then is why, once I used the _ss_environment.php does the system not just look in the database for the admin user any more. I commented out the require_once("conf/ConfigureFromEnv.php"); line from _config.php so it would not define any variables.

It is not really a problem since I can set the default admin in the _config.php, but I would rather not expose the login info in a file on the server.

Avatar
saemmi

13 February 2009 at 9:58pm (Last edited: 13 February 2009 10:01pm), Community Member, 6 Posts

Argh...
After installing, which finally worked with the actual RC, it says login with admin:admin password:password as default.
this doesn't work.
tried to write it into _config.php, result is a screen with multiple errors (see attached image)

it is really sad. when i tried out silverstripe half a year ago, everything was fine. now i am sitting and trying to install since 3 days...

edit: it was a php syntax error: everybody else with this problem use:

Security::setDefaultAdmin('admin','password');

Attached Files
Avatar
Ricardo

14 February 2009 at 4:17am Community Member, 11 Posts

Iam now able to login . I used "Securityset etc" as advised
Thanks for the support

Avatar
CompNrd

15 October 2013 at 6:45am Community Member, 2 Posts

I am using 2.4.5 and I have tried everything to reset the forgotten password...

Any hits guys?