Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Silver stripe search


Reply

15 Posts   5724 Views

Avatar
AndrewMK

27 February 2009 at 11:59am Community Member, 23 Posts

So today i decided to test the full text search index directly on PHPmyadmin to make sure it would match three letter words and i ran the following code:

SELECT title FROM sitetree WHERE MATCH(title) AGAINST ('pim')

and it does find all the rows where the title columns contain the word 'pim'.
But yet when i search in SS from my site i still get NO results??????

Avatar
AndrewMK

27 February 2009 at 12:24pm Community Member, 23 Posts

So i discovered something else of interest!

In this site i also have an 'advanced' search which uses a custom searchcontext on one of my classes i created. when i search via this method i can return 3 letter words????????

Avatar
weberho

27 February 2009 at 9:57pm Community Member, 15 Posts

I've tested it on my site, and it works resonably well here. There are some Stopwords which are documented here http://dev.mysql.com/doc/refman/5.1/en/fulltext-stopwords.html which never can be found using the MySQL fulltext search tools.

If your search-engine is searching in another table the sitetree, you have to repair this table, too. So I recomment repairing all tables just to be sure.

Johannes

Avatar
AndrewMK

2 March 2009 at 8:53am Community Member, 23 Posts

IT WORKS!!!!

For some reason after making the changes described by WeberHo i had to go and republish all the pages containing the 3 letter words.

Avatar
tobych

2 March 2009 at 9:36am Community Member, 97 Posts

I imagine rebuilding the relevant index(es) on the MySQL table would be an alternative to republishing the articles.

Avatar
AndrewMK

2 March 2009 at 9:38am Community Member, 23 Posts

Yeah so did i and i tried that too I went into phpmyadmin and 'altered' the index and also tried doing a 'repair' of the table. but neither worked then i republished a page and it worked.

Avatar
borriej

24 January 2011 at 10:29pm (Last edited: 24 January 2011 10:29pm), Community Member, 267 Posts

I'm having the search problem..!

I've read this thread, but i don't understand it. (e.g. where can i find my.cnf)

So can some one please tell me in short what i need to do to:
- Find pages when using 3 character strings in the SilverStripe searchbox?

Thx!