Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

2.2.3 Embedding Files into Content Textarea


Reply

941 Views

Avatar
HangingClowns

20 February 2009 at 9:34am Community Member, 1 Post

Find it impossible to embed a simple mov into the content pane. I've tried editing the Tiny MCE config file:

function nullConverter(url) {
   return url;
}

/**
* TinyMCE initialisation template.
* $ variables are replaced by string search & replace. It's pretty crude.
*/
// Prevents "Error: 'tinyMCE' is undefined" error in IE7 on Newsletter Recipient import.
if((typeof tinyMCE != 'undefined')) {
   tinyMCE.init({
      mode : "specific_textareas",
      language: "$Lang",
      textarea_trigger : "tinymce",
      width: -1,
      height: -1,
      auto_resize : true,
      theme : "advanced",
      content_css : "$ContentCSS",
      document_base_url: "$BaseURL",
      urlconverter_callback : "nullConverter",
      
      setupcontent_callback : "sapphiremce_setupcontent",
      cleanup_callback : "sapphiremce_cleanup",
      
      Theme_Advanced_Layout_manager : "SimpleLayout",
      theme_advanced_toolbar_location : "manually_placed",
      theme_advanced_toolbar_align : "left",
      theme_advanced_toolbar_parent : "right",
      plugins : "contextmenu,table,emotions,flash,paste",   
      table_inline_editing : true,
      theme_advanced_buttons1 : "italic,underline,strikethrough,separator,justifyleft,justifycenter,justifyright,justifyfull,styleselect,formatselect,separator,bullist,numlist,outdent,indent,hr,charmap",
      theme_advanced_buttons2 : "undo,redo,separator,cut,copy,paste,separator,search,replace,separator,flash",
      theme_advanced_buttons3 : "",
      theme_advanced_buttons3_add : "emotions",
   /*
      theme_advanced_buttons1 : "bold,italic,underline,strikethrough,separator,justifyleft,justifycenter,justifyright,justifyfull,styleselect,formatselect,separator,bullist,numlist,outdent,indent,hr,charmap",
      theme_advanced_buttons2 : "undo,redo,separator,cut,copy,paste,separator,search,replace,separator,link,unlink,anchor,image,separator,cleanup,removeformat,visualaid,code,separator,tablecontrols",
   */   
      safari_warning : false,
      relative_urls : true,
      verify_html : true,
      
      //** Changed these to allow the embedding of mov files. **//
      valid_elements : "*

  • ", //"+a[id|rel|rev|dir|tabindex|accesskey|type|name|href|target|title|class],-strong/-b[class],-em/-i[class],-strike[class],-u[class],#p[id|dir|class|align],-ol[class],-ul[class],-li[class],br,img[id|dir|longdesc|usemap|class|src|border|alt=|title|width|height|align],-sub[class],-sup[class],-blockquote[dir|class],-table[border=0|cellspacing|cellpadding|width|height|class|align|summary|dir|id|style],-tr[id|dir|class|rowspan|width|height|align|valign|bgcolor|background|bordercolor|style],tbody[id|class|style],thead[id|class|style],tfoot[id|class|style],-td[id|dir|class|colspan|rowspan|width|height|align|valign|scope|style],-th[id|dir|class|colspan|rowspan|width|height|align|valign|scope|style],caption[id|dir|class],-div[id|dir|class|align],-span[class|align],-pre[class|align],address[class|align],-h1[id|dir|class|align],-h2[id|dir|class|align],-h3[id|dir|class|align],-h4[id|dir|class|align],-h5[id|dir|class|align],-h6[id|dir|class|align],hr[class],dd[id|class|title|dir],dl[id|class|title|dir],dt[id|class|title|dir]",
          extended_valid_elements : "*
  • " //"img[class|src|alt|title|hspace|vspace|width|height|align|onmouseover|onmouseout|name]"
       });
    }

But, when I type into the HTML editor

<embed src="some_reference_to_mov"></embed>

I would automatically get:

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,29,0" width="undefined" height="undefined"><param name="movie" value="some_reference_to_mov" /><param name="quality" value="high" /><param name="menu" value="false" /><param name="wmode" value="transparent" /><embed src="some_reference_to_mov" wmode="transparent" quality="high" menu="false" pluginspage="http://www.macromedia.com/go/getflashplayer" type="application/x-shockwave-flash" width="undefined" height="undefined"></embed></object>some_reference_to_mov&quot;


in it's place. Is there a fix for this?