Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

i think i've broken my db...


Reply


4 Posts   1025 Views

Avatar
redcirce

Community Member, 22 Posts

25 February 2009 at 5:07pm

Hi. When I try http://localhost:3000/db/build?flush=1 in my browser (both Chrome and Firefox), I get a 404 error: Not Found. The requested URL /db/build was not found on this server.

It was working earlier today... any ideas on how to fix?

Avatar
Fuzz10

Community Member, 787 Posts

25 February 2009 at 9:56pm

In 2.3 , you need to go to /dev .....

Avatar
Carbon Crayon

Community Member, 598 Posts

26 February 2009 at 4:41am

or if your running 2.23 try it without the ":3000". Also if you are using a project folder it needs to be

http://localhost/folderName/db/build?flush=1

Avatar
redcirce

Community Member, 22 Posts

26 February 2009 at 11:32am

Edited: 26/02/2009 11:36am

I'm using 2.2.3. http://localhost/db/build?flush=1 doesn't work either (I'm not using a project folder). This happened suddenly yesterday after hours of it working without problems.

I tried finding a solution for 4 hours and all I could find were other people having similar problems but no solution!

Today I think I'm just going to have to try reinstalling everything (but keeping copies of mysite & templates of course!).

For the record, I checked my apache error log and found this:

[Thu Feb 19 15:02:53 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.8 configured -- resuming normal operations
[Thu Feb 19 15:02:53 2009] [notice] Server built: Dec 10 2008 00:10:06
[Thu Feb 19 15:02:53 2009] [notice] Parent: Created child process 1264
[Thu Feb 19 15:02:53 2009] [notice] Child 1264: Child process is running
[Thu Feb 19 15:02:53 2009] [notice] Child 1264: Acquired the start mutex.
[Thu Feb 19 15:02:53 2009] [notice] Child 1264: Starting 64 worker threads.
[Thu Feb 19 15:02:53 2009] [notice] Child 1264: Starting thread to listen on port 3000.
[Thu Feb 19 15:03:25 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Feb 19 15:03:25 2009] [notice] Child 1264: Exit event signaled. Child process is ending.
[Thu Feb 19 15:03:26 2009] [notice] Child 1264: Released the start mutex
[Thu Feb 19 15:03:27 2009] [notice] Child 1264: All worker threads have exited.
[Thu Feb 19 15:03:27 2009] [notice] Child 1264: Child process is exiting
[Thu Feb 19 15:03:27 2009] [notice] Parent: Child process exited successfully.
[Thu Feb 19 15:03:27 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.8 configured -- resuming normal operations
[Thu Feb 19 15:03:27 2009] [notice] Server built: Dec 10 2008 00:10:06
[Thu Feb 19 15:03:27 2009] [notice] Parent: Created child process 1400
[Thu Feb 19 15:03:27 2009] [notice] Child 1400: Child process is running
[Thu Feb 19 15:03:27 2009] [notice] Child 1400: Acquired the start mutex.
[Thu Feb 19 15:03:27 2009] [notice] Child 1400: Starting 64 worker threads.
[Thu Feb 19 15:03:27 2009] [notice] Child 1400: Starting thread to listen on port 3000.
[Thu Feb 19 15:07:23 2009] [notice] Parent: Received shutdown signal -- Shutting down the server.
[Thu Feb 19 15:07:23 2009] [notice] Child 1400: Exit event signaled. Child process is ending.
[Thu Feb 19 15:07:24 2009] [notice] Child 1400: Released the start mutex
[Thu Feb 19 15:07:27 2009] [notice] Child 1400: All worker threads have exited.
[Thu Feb 19 15:07:32 2009] [notice] Child 1400: Child process is exiting
[Thu Feb 19 15:07:32 2009] [notice] Parent: Child process exited successfully.
[Thu Feb 19 15:07:32 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.8 configured -- resuming normal operations
[Thu Feb 19 15:07:32 2009] [notice] Server built: Dec 10 2008 00:10:06
[Thu Feb 19 15:07:32 2009] [notice] Parent: Created child process 2120
[Thu Feb 19 15:07:33 2009] [notice] Child 2120: Child process is running
[Thu Feb 19 15:07:33 2009] [notice] Child 2120: Acquired the start mutex.
[Thu Feb 19 15:07:33 2009] [notice] Child 2120: Starting 64 worker threads.
[Thu Feb 19 15:07:33 2009] [notice] Child 2120: Starting thread to listen on port 3000.
[Thu Feb 19 15:10:32 2009] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico
[Thu Feb 19 15:12:55 2009] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico
[Thu Feb 19 15:14:33 2009] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico
[Thu Feb 19 15:17:13 2009] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico
[Thu Feb 19 15:17:33 2009] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico
[Thu Feb 19 15:21:41 2009] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico
[Thu Feb 19 15:22:21 2009] [error] [client 127.0.0.1] File does not exist: C:/wamp/www/favicon.ico (and repeat ad nauseum)