Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Subsite module - Who can run and access to them?


Reply


4 Posts   1179 Views

Avatar
Uzenmi

Community Member, 19 Posts

21 March 2009 at 3:53am

Hi all,

I download SS v3.1.2 and Subsite newest module, installed on localhost and webserver successfully, created subsite in CMS okay too, but I can not access URL (ex, http://subsite.mywebsite.com) with 404 error even I read [url=http://doc.silverstripe.com/doku.php?id=modules:subsites]documents[/url] very carefully.
So who can done that? And show me how to fix that?

Thanks very much,

Avatar
Willr

Forum Moderator, 5513 Posts

21 March 2009 at 2:26pm

Have you setup the VirtualHosts (for apache, no idea what they are called on IIS) so that subdomain.mysite.com points to mysite.com/?

Avatar
Uzenmi

Community Member, 19 Posts

21 March 2009 at 6:17pm

Edited: 21/03/2009 6:18pm

Yes, the first I loged in to CMS, created a new subdomain in Subsites section, then I loged in to hosting control panel, pointed that subdomain to domain that its running SS but subdomain still does not work :( I really dont know why?!

Avatar
mishell

Community Member, 19 Posts

2 July 2009 at 4:53am

Were You able to fix this problem ? I have same issue on localhost.

Added new VirtualHost, c:\windows\....\hosts, flushed DNS, smoked a lot of cigaretes and nothing 404 stilll on my screen.