Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Site defaulting to login page.


Reply

8 Posts   1484 Views

Avatar
designerdre

27 March 2009 at 5:07am Community Member, 19 Posts

Rather than displaying the homepage of the website when the homepage URL is requested it redirects to /Security/login. Instead of spending hours poking around I'm hoping that someone would be able to graciously give me the guidance that is needed here.

Avatar
banal

30 March 2009 at 7:55pm Community Member, 901 Posts

Hi.
I'm not sure if;
a) You're trying to get Security/login to show up whenever somebody visits your home-page. Or...
b) Your problem is, that Security/login shows up where your home-page should be.

To solve a)
You could change your home-page to a redirector page (Behaviour tab), pointing to Security/login.

To solve b)
Have a look at the "Access" tab of your home-page. Do some restrictions apply there?

Best - Roman

Avatar
designerdre

3 April 2009 at 11:27am Community Member, 19 Posts

Thanks a million! My problem was (b) and your suggestion worked. Thanks again.

Avatar
Junglefish

25 August 2010 at 9:22pm Community Member, 104 Posts

I'm having the same problem (ie. b above), but my access tab settings seem fine. Where else can I look?

jf/

Avatar
1k2k3

30 August 2010 at 6:31pm (Last edited: 30 August 2010 6:41pm), Community Member, 15 Posts

try doing and it will recreate the homepage.

http://localhost/silverstripe/dev/build

Also look into index.php file within the SilverStripe Directory.

Avatar
Junglefish

30 August 2010 at 7:21pm Community Member, 104 Posts

Hi 1k2k3

I have already tried re-building several times, but no joy there.

Can you tell me which index.php you are referring to? There isn't one directly in the SilverStripe directory.

jf/

Avatar
1k2k3

31 August 2010 at 4:56pm (Last edited: 31 August 2010 5:01pm), Community Member, 15 Posts

So If you delete "home" you will get an error. If you then flush the database it will recreate a "home" page.

http://localhost/silverstripe/dev/build/?flush=1

After flushing the database, change the page type of the homepage in the CMS, under the “Behaviour” tab. Change it to HomePage, and click “Save Draft” and “Publish”.
reference: [url]http://doc.silverstripe.org/tutorial:1-building-a-basic-site[/url]

Well my silverstripe has an Index.php file inside the root directory, I'm not sure whether or not its relevant I was just saying you could give it a go. But I'd recommend flushing your DB and then recreating a new homepage.

Attached Files
Avatar
Junglefish

31 August 2010 at 8:19pm Community Member, 104 Posts

Hi again

Yep, in fact that's what I had to do - destroy my old homepage and recreate a new one. Why would I have to do this? I'm still not sure. I took a look in the database to see if there was something odd about the old record but nothing stood out.

So, for me, case closed, but I'm not really much the wiser...

jf/