Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Problem with Save and Publish function


Reply

4 Posts   1226 Views

Avatar
kompideal

30 March 2009 at 6:15am Community Member, 7 Posts

Hi,
I have problem which is causing a lot of problems dealing with content.
I have made all structure of my website but when I modify something in these pages and push Save and Publish button, nothing is saved and only error message is displayed: Javascript Parse Error.

Please help to deal with this problem. Thank you.

My Silverstripe version: 2.3.0

Avatar
theAlien

30 March 2009 at 7:01am Community Member, 131 Posts

I know that. It happens on my local wamp-server (not on my productionserver). I have a solution, but it's very much automated in my mind, so I'm not sure which one it actually is. Try one of these:
- restarting your (wamp)-server (provided your working on a local (test)server or have access to your server)
- refreshing your myURL/admin
- running a /dev/build (not very likely that will work though)

Avatar
kompideal

30 March 2009 at 8:00am Community Member, 7 Posts

Thanks for solutions but:
1. As you said, running a /build don't helps
2. Refreshing myURL/admin? Refreshing browser or what?
3. Wamp... I am working on shared hosting (this means that I have no control for restarting server)

Any solutions...?

Avatar
theAlien

30 March 2009 at 8:16am (Last edited: 30 March 2009 8:17am), Community Member, 131 Posts

2. Yeah, refreshing browser while you're in admin
3. check with your hostingprovider if their server-setup is OK. Server-sequirements of SS are for example a memory-limit of 32 MB (a little bit below that should also work in my experience, but not to much of course. Maybe it's possible to bypass the server-setup as suggested [url=http://doc.silverstripe.org/doku.php?id=server-requirements#php]here[/url].
4. If nothing works, still: check with your hostingprovider and explain them js isn't working well. Maybe they know something?

Unfortunately I don't have any further suggestions. For me: everything that worked badly on my local wamp-installation went fine as soon as I put my site online, so I'm pretty convinced it's in the server and not in SS. Please let us know however if some (or none) of these worked for you.