Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

some general questions


Reply


3 Posts   807 Views

Avatar
hiks

Community Member, 7 Posts

1 April 2009 at 1:59pm

Hi everybody,

I "found" SliverStripe while using the MS Web Platform Installer and I'am really fascinated! I'am working on my site since months but well don't talk about the results^^

Now I'm "playing" with SilverStripe to learn how to configure, but there're some basic questions:
1. Is it possible to install several SilverStripe application on the same server (in several folders but with just one! MySQL-DB)? I thought about a basic site with one theme for all users and a developer area with another theme, other menu, other...
2. How about having several languages? How to arrange, just saw a language selector widget but don't know how to get a second language.

thx

Avatar
Willr

Forum Moderator, 5513 Posts

1 April 2009 at 4:40pm

1) You can try out the subsites module http://doc.silverstripe.com/doku.php?id=modules:subsites which enables you to have multiple sites from the 1 admin. It is beta code and not yet fully stable and I don't know if its ever ran on IIS but you can always try it out

2) Did you want multilanguages on the front end or the backend or both?. Currently multiply languages is a tad bit broken in 2.3. This should be fixed in an upcoming update for more information on that see http://doc.silverstripe.com/doku.php?id=multilingualcontent

Avatar
hiks

Community Member, 7 Posts

2 April 2009 at 1:56am

Thanks,

with the knowledge, that there seems to be a way, I won't use IIS any longer and test it "live" on my Apache webserver. Cause I don't want to make all double and on my local IIS server it need very long time to load a site, at the beginning it as running very quick, then I enabled widgets on every page and since then it needs 10seconds or more to load a site. Hope it will run faster on the apache machine, cause I want to have widgets on my home page and don't want to get trouble with my host^^