Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

DTD defintion problem in IE 6.0


Reply

5 Posts   1684 Views

Avatar
yeahnahyeah

4 April 2009 at 3:21pm (Last edited: 4 April 2009 10:17pm), 3 Posts

I get this error when trying to open a 2.3.0 version of SS in Internet Explorer 6.0.

The XML page cannot be displayed
Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later.

--------------------------------------------------------------------------------

Parameter entity must be defined before it is used. Error processing resource 'http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd...

%xhtml-prefw-redecl.mod;
-^

It seems to be having a problem with the "xhtml11.dtd".

Any ideas on how to fix this?

Avatar
Willr

7 April 2009 at 9:07pm Forum Moderator, 5511 Posts

Have you tried 2.3.1?

Avatar
yeahnahyeah

7 April 2009 at 9:52pm 3 Posts

Updated to 2.3.1 tonight actually.

Still no joy with IE 6.0. It works fine on Firefox, And IE 7.0 on home PC. Just get the error on work PC using IE 6.0.

Avatar
SiteStuffMike

23 April 2009 at 7:31am Community Member, 4 Posts

I am having the same error appear only on machines running IE 6 who installed the latest Service Pack from Microsoft. Those that have not installed the service pack work fine, and those who are running other broswers or even IE 7 work fine. Just IE 6 with the latest Service Pack.

Error:

"The XML page cannot be displayed

Cannot view XML input using style sheet. Please correct the error and then click the Refresh button, or try again later.
Parameter entity must be defined before it is used. Error processing resource 'http://www.w3.org/TR/xhtml11/DTD/xhtml11.dtd...

%xhtml-prefw-redec1.mod;
-^
"
Any help from the developers would be very welcome!

Avatar
slang

27 April 2009 at 11:12pm Community Member, 6 Posts

I'm also having a very similar problem.

Only on IE6 (probably latest patch), and only with Silverstripe 2.3.1. The same template on a 2.3.0rc2 doesn't throw the xml error at all.

Any suggestions on where to look for more detail/a fix?

Cheers -