Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Unable to Log In


Go to End
Reply


10 Posts   2075 Views

Avatar
growin

Community Member, 41 Posts

8 May 2009 at 5:52pm

My site was moved and I'm now unable to log in. Is there a mysql querie that can clear up which logins are existing? The site works as made but the log in page no longer allows me to login as I did before. I'd like to figure out what is in the database for admin ID's and if the passwords are still there. Thanks!

Avatar
banal

Community Member, 901 Posts

8 May 2009 at 7:21pm

You can add the following line to your _config.php file:

Security::setDefaultAdmin("admin", "yourpass");

Then you can log in with admin//yourpass. That should allow you to check the accounts and re-set passwords. After doing so, you should remove the line from _config.php though.

Avatar
growin

Community Member, 41 Posts

17 May 2009 at 6:27am

Thanks for that. I did the change and still no ability to log in. Not sure what to do now. I can't change anything on the site. Help!

Avatar
banal

Community Member, 901 Posts

17 May 2009 at 6:54am

It should work...
Did you add the line to mysite/_config.php ?

Avatar
growin

Community Member, 41 Posts

17 May 2009 at 5:49pm

Yes, that's the file I added the line to. I ftp'd, copied the file to the hard-drive, added the line and uploaded the file over-writing the original file. Does it matter where the line is located in the file?

Avatar
banal

Community Member, 901 Posts

17 May 2009 at 8:28pm

Edited: 17/05/2009 9:06pm

No, I don't think it would matter where you put that in your file. Just put it at the end to be sure :)
And after doing so, you're not able to log in with the username and password you set in the setDefaultAdmin function?

Update: Oh yeah, and make sure you have cookies enabled for your site. Also check the Firebug console if there are any errors.

Avatar
cshtauralrets

Community Member, 9 Posts

17 June 2009 at 2:31pm

By the way, I solved my issue by appending

?isDev=1

to my sign in url. It turned out my

php.ini

was set to try and store cookies in a location which didn't exist.

Avatar
growin

Community Member, 41 Posts

14 October 2009 at 12:35pm

I went back to this site and re-installed. I still can't log in to the cms. in dev mode I get this error: "[Warning] Unknown: open(/var/lib/php/session/sess_kn54gimdp6tfjnq8pqvd2vgnv0, O_RDWR) failed: Permission denied (13)
GET /Security/login?isDev=1

Line 0 in Unknown"

Now what?

Go to Top