Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Admin Panel not Loading


Go to End
Reply

10 Posts   4344 Views

Avatar
tonisch

9 May 2009 at 12:13am (Last edited: 9 May 2009 12:14am), Community Member, 15 Posts

Hi toghether!

I have a big problem: after a day working normal in the admin panel, today its not loading any more. I testet it with Safari, Firefox, IE 7 + 8, and it doesn't load. I just get the image: loading... Welcome to Silverstripe and thats it.
My Firebug Console says:

Class ss.i18n not defineden_US.js...229296748 (Linie 2)
Class ss.i18n not defineden_US.js...231098970 (Linie 2)
Class is not defined
[Break on this error] FieldEditor = Class.create();
FieldEdi...229303404 (Linie 1)
Class is not defined
[Break on this error] ToolbarForm = Class.create();
tiny_mce...237164362 (Linie 1)
Behaviour is not defined
[Break on this error] Behaviour.register({
admin (Linie 512)
Behaviour is not defined
[Break on this error] Behaviour.register({
admin (Linie 790)
Behaviour is not defined
[Break on this error] Behaviour.register({
admin (Linie 723)
Behaviour is not defined
[Break on this error] Behaviour.register({
admin (Linie 740)

You can test it yourself on [url]www.tonisch.de/admin[/url]. The user ist »test@test.de«, passw: »thomas«.

Thanx in advance!

Avatar
banal

9 May 2009 at 1:06am (Last edited: 9 May 2009 1:09am), Community Member, 901 Posts

Yup, there are some required javascript files that aren't loaded (as you can see in the "net" tab of firebug).
assets/base.js
assets/leftandmain.js
assets/cmsmain.js
I get a 403 (permission denied) error on these assets. I guess you should have a look at the folder permissions and set them at least to readable (chmod 0644)

Edit hmm. why are these placed in /assets/ ? There's something wrong i guess. What does your .htaccess look like?

Avatar
tonisch

9 May 2009 at 1:57am Community Member, 15 Posts

Hej!

I made some changes bevor i read your comment - so I could not recognize what you wrote. I started to load the /jsparty again to the site. Now the Problem is solved, but I think it will be there again by tomorrow.
Thanks for the advice with the firebug:net feature. I almost forgot having this feature already implemented in firebug.
I will keep your comment in mind and report to you tomorrow if the problem stays on...

Thanx!

Avatar
tonisch

9 May 2009 at 2:03am (Last edited: 9 May 2009 2:06am), Community Member, 15 Posts

So, the error is back on.
My /.htaccess file is:

### SILVERSTRIPE START ###
<Files *.ss>
Order deny,allow
Deny from all
Allow from 127.0.0.1
</Files>

<IfModule mod_rewrite.c>
RewriteEngine On
RewriteBase /

RewriteCond %{REQUEST_URI} !(\.gif)|(\.jpg)|(\.png)|(\.css)|(\.js)|(\.php)$

RewriteCond %{REQUEST_URI} ^(.*)$
RewriteCond %{REQUEST_FILENAME} !-f
RewriteRule .* sapphire/main.php?url=%1&%{QUERY_STRING} [L]
</IfModule>
### SILVERSTRIPE END ###

and, the asstes folder got the permission: 0750
and, giving the *.js in the assets-folder the permission: 0640 its displaying just something, like the sitetree. but not more...

Avatar
tonisch

9 May 2009 at 2:13am Community Member, 15 Posts

I dont get it.
I've uploaded the .htaccess file of the installation package and now it works. but I tried this already yesterday and nothing happend...
Its really weird....

Avatar
tonisch

9 May 2009 at 6:03am Community Member, 15 Posts

Problem solved!

setting the right permissions in the asset-folder for the files: base.js, cmsmain.js and leftmain.js I get access to the admin panel.
But could someone tell me, why these files are in this directory??

Avatar
sonicparke

15 June 2009 at 7:40am 74 Posts

I'm having this same problem but it's still not resolved yet. What are the correct permissions for the 3 js files? I've got them all at 755 right now, re-uploaded jsparty & still not working.

Avatar
tonisch

15 June 2009 at 7:53am Community Member, 15 Posts

Hi!

I gave them all 640. And the »assets« Folder got 750. But my Webserver need some special treatment with the file-rights.
Firebug for Firefox helped me debugging the Permission - Errors.

Good luck!

Go to Top