Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[Translatable] Some problems


Reply


3 Posts   684 Views

Avatar
Edu115

Community Member, 13 Posts

11 July 2009 at 1:06pm

Edited: 11/07/2009 1:08pm

Hi there,

I'm having some troubles getting Translatable to work in 2.3.2.

I don't know if I'm doing everything as I should, but I think so.

I added these lines in mysite/_config.php

Object::add_extension('SiteTree', 'Translatable');
Translatable::set_default_locale('pt_PT');

And then, in the Admin page, I made some changes. My old default locale was en_US, but my content was in Portuguese. So I created a new Portuguese translation, I put there my original content, and then I put the English content in my original English translation.

The thing is, everything is messed up now. When I choose the Portuguese translation, the site tree on the left gets completely messed up.
Also, when I try to put /?locale=pt_PT in front of the URLs, the content stays in English.

I wanted to try to delete the translation files, but I can't seem to find a way of doing it.

Thank you,
Eduardo

Avatar
Edu115

Community Member, 13 Posts

13 July 2009 at 1:57am

When I open the Portuguese translation, the site tree on the left has different pages from the one that appears in the default English translation.

I'm trying to find that in the db, in order to delete those rows, but I'm afraid I mess up.

Avatar
Edu115

Community Member, 13 Posts

13 July 2009 at 3:33am

Edited: 13/07/2009 3:34am

"Página Principal" is the translated value of "Main Page".