Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

.js errors


Reply


962 Views

Avatar
BruceG

Community Member, 29 Posts

4 August 2009 at 11:15pm

Edited: 04/08/2009 11:30pm

I appear to have a javascript problem that prevents quite a few things happening correctly.
Might be an IE problem because when viewing the site http://themes.silverstriped.com/ I get this error

Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Tue, 4 Aug 2009 11:11:58 UTC

Message: Object doesn't support this property or method
Line: 35
Char: 3
Code: 0
URI: http://themes.silverstriped.com/wp-content/themes/gallery/js/gallery.js

I also get similar errors when in the CMS and when viewing my own site.

In the CMS looking at Gallery page I get
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Tue, 4 Aug 2009 11:19:08 UTC

Message: Member not found.

Line: 10
Char: 4
Code: 0
URI: http://www.afsm.org.nz/jsparty/behaviour.js?m=1248533609

Message: Member not found.

Line: 10
Char: 4
Code: 0
URI: http://www.afsm.org.nz/jsparty/behaviour.js?m=1248533609

In the newsletter section on mailing list I get this
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; GTB6; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)
Timestamp: Tue, 4 Aug 2009 11:27:49 UTC

Message: Member not found.

Line: 162
Char: 190
Code: 0
URI: http://www.afsm.org.nz/assets/base.js?m=1249274963

Message: Member not found.

Line: 162
Char: 190
Code: 0
URI: http://www.afsm.org.nz/assets/base.js?m=1249274963

Message: Member not found.

Line: 162
Char: 190
Code: 0
URI: http://www.afsm.org.nz/assets/base.js?m=1249274963

Message: 'SiteTree' is undefined
Line: 6
Char: 1
Code: 0
URI: http://www.afsm.org.nz/newsletter/javascript/NewsletterAdmin_left.js?m=1248911266

Message: 'CMSForm' is undefined
Line: 75
Char: 1
Code: 0
URI: http://www.afsm.org.nz/newsletter/javascript/NewsletterAdmin_right.js?m=1248911266

Does anyone have any ideas about how i can rectify this problem? apart from ditching IE!!
Currently using IE8

Thanks
BruceG