Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

How to show pdf


Go to End
Reply


11 Posts   3480 Views

Avatar
Platypus

Community Member, 43 Posts

21 October 2009 at 6:36am

This worked for me regarding the embedding of iframe-code: http://www.silverstripe.org/general-questions/show/255938?start=0#post257773

Thx again to banal for this solution :-)

Avatar
kaloschke

Community Member, 8 Posts

23 October 2009 at 5:13am

Hi Platypus,
thank you very much. That is exactly what I need. But I can't get it running! So I'm new to Silverstripe I like to explain, what I have done:
- Under mysite/code I created a new file 'embedpage.php' and include there the code from your link
- In templates/layout/page.ss I include $embedcode as described in the link
- I start localhost/myproject/dev/build?flush=1 to rebuild the database

At this point, I think I should see under 'Creating database records' my new typ 'embedpage' or am I wrong?

Anyway, when I create a new page there is no embedpage in the list.
Do you or anyone else has an idea, what is wrong?

Greetings Kaloschke

Avatar
kaloschke

Community Member, 8 Posts

23 October 2009 at 5:36am

OK. it works.
Solution is simple (now :-) ). I run silverstripe on a windows system. First I used IIS, then XAMPP. I simply forgot to stop the IIS, so I did not see the project that I expected to see. Very stupid, I know.
But now everything works fine and I have learnd a lot.

Thank you everybody for your help.
Kaloschke

Go to Top