Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Why is it this slow!?


Go to End
Reply


13 Posts   3469 Views

Avatar
BigJohn

Community Member, 3 Posts

10 January 2010 at 5:33am

Dear Dina,
Seems like your site is running pretty smooth right now! Dit you find a solution? I'm very interested since I experience similar problems.

Avatar
DinaHansen

Community Member, 10 Posts

10 January 2010 at 7:04am

Hello :)

I haven't done anything, but it seems, that my database server at Servage is slow at times. This has mostly been a problem during high traffic hours. I've still problems with the site, that is very very slow at times, but mostly it has become noticeably faster. I believe, that Servage has looked at my problem after I contacted them, but I don't know what they've done.

/Dina

Avatar
AlexB

Community Member, 4 Posts

8 February 2010 at 5:16am

Edited: 08/02/2010 5:28am

I have consistently found that if the /assets directory does not have the right permissions set SilverStripe runs very slowly. This contains the default upload directory - SS upload functions will not work if write permissions are not correctly set. The settings:

chmod -R 777 assets

Before finding this, I did look on the forum for mention of a solution to the speed problem with no luck. It does seem that a great many people have been frustrated with this issue, and I gather many have criticisized and abandoned SS as a slow platform - unfairly. Why is this simple answer not plastered all over this forum? Is there more to it than this?

Avatar
stallain

Community Member, 61 Posts

24 June 2010 at 11:13pm

Thanks a lot, Alex !
I've just tried it on a specially slow site, and IT WORKS !

Avatar
XannaX

Community Member, 6 Posts

19 August 2011 at 10:01am

chmod /assets to -R 777 totally worked thank you!

Go to Top