Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

redirect to a subfolder


Reply


3 Posts   1069 Views

Avatar
nuker669

Community Member, 10 Posts

8 October 2009 at 1:58am

Edited: 08/10/2009 2:14am

I just rebuilt one of our websites using silverstripe. amazing product.

I have forum which is stored in a folder in the site root.

i create a redirector page within SS with a url to the folder (http://www.mysite.com/folder)

i have tried using the folder name without the domain, etc... as the url and same result.

it will only work if i add index.php to the url. but this is not ideal as we have alot of people who have the site bookmarked.

I get the SS error page with the following message:

Website Error
Not Found
The website server has not been able to respond to your request.

how do i get this to work?

Avatar
baba-papa

Community Member, 279 Posts

8 October 2009 at 7:16pm

I don´t know why you used a redirect page. Maybe you can use the method "redirect" from the class "Director".

Avatar
zenmonkey

Community Member, 528 Posts

9 October 2009 at 12:17pm

If its just a link to static target, why don;t you code the URL in the template.

But if you're using other Forum software that resides in that folder it should work without the index.php unless it has its own htaccess URL rewrites, then I can see it causing problems. The SS install may have overwritten its rules.