Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Error saving Content in SubPage


Reply


5 Posts   1763 Views

Avatar
Neobe

Community Member, 7 Posts

17 October 2009 at 5:29am

Hi,

I´m trying to add html Code with the help of the Wysiwyg HtmlPlugin to one of my subpages,

Actually it works but when I´m trying to save or publish it there´s always the text "Error saving content".

Could you help me finding the error ?

Thanks a lot for your help

Neobe

Avatar
Willr

Forum Moderator, 5513 Posts

17 October 2009 at 11:33am

Hi Neobe, usually helps if you post a link to the code or the code in question here so we can look at it.

One thing you can try with the cms bugs is put the site in dev mode by adding

Director::set_environment_type("dev");

to your mysite/_config.php file then reload the cms and try and save the page again - this time when the error pops up have a look at the console panel (this would be using firefox) and you should see the actual error returned by SilverStripe.

Commonly the issue is when you have added a field in the cms but haven't added the database record, or rebuilt the database so make sure you run http://www.yoursite.com/dev/build to rebuild your database.

Avatar
Neobe

Community Member, 7 Posts

19 October 2009 at 9:49pm

Hi Willr,

thank you for the quick respone... Actually this is the code I want to add

<div id="contentMainColumn">

<a class="contentButtons contentButtonsTop registerButton" href="https://ssl.kontoblick.de/registration/">kostenlos Registrieren</a>
<h2>Behalten Sie den Ãœberblick, was mit Ihrem Geld geschieht</h2>

<a id="kurzcheck" name="kurzcheck"/>
<div class="feature featureLeft">
<h3>Ihre Finanzsituation im Kurzcheck</h3>
<p class="featureTeaser"><img src="/static/v3458/images/screenshots/situation.jpg"/>Verfolgen Sie den Kontostand mehrerer Konten oder Ihren Gesamtsaldo in einer ansprechenden grafischen Darstellung. </p>
<p>Profitieren Sie von der eingängigen grafischen Darstellung, um die richtigen Schlüsse für Ihr Finanzverhalten zu ziehen!</p>
</div>

<div class="contentBoxLine"><div/></div>

<a id="verteilung" name="verteilung"/>
<div class="feature featureRight">
<h3>Einnahmen-Ausgaben-Verteilung</h3>
<p class="featureTeaser"><img alt="Ausgaben im Detail" src="/static/v3458/images/screenshots/verteilung.jpg"/>In einer übersichtlichen Darstellung sehen Sie die Aufteilung Ihrer Ausgaben, Einnahmen und Vorsorge-Investitionen auf einen Blick. </p>
<p>Für detailliertere Informationen wählen Sie einfach eine bestimmte Kategorie aus. <b>kontoblick</b> liefert Ihnen sofort die Aufteilung in die zugeordneten Unterkategorien. Ein weiterer Klick und Sie sehen die einzelnen Zahlungspartner. Noch ein Klick und Sie landen direkt bei den passenden Transaktionen. In wenigen Schritten kommen Sie von ganz grob zu ganz fein.</p>
</div>

<div class="contentBoxLine"><div/></div>
</div>

and so on... So, the problem is first of all this <a id="kurzcheck" name="kurzcheck"/> doesn´t work in Silverstripe when I try to save it SS always says Error saving Content, also this <div class="contentBoxLine"><div/></div> doesn´t work because SS just deletes this line... what could I do to fix this error ?

Thanks a lot
Best regards Neobe.

Avatar
Neobe

Community Member, 7 Posts

19 October 2009 at 10:34pm

There is also this problem appearing

<ul id="videoPlaylist">
<li name="steps01" id="steps01" class="current">
<a href="#steps01"><span class="captionLabel">Erste Schritte: </span>
<span class="caption">Konto mit Direktabruf anlegen</span><img src="/static/v3458/images/external/video/steps01s.png"/>
</a>
</li>
<li name="steps02" id="steps02">
<a href="#steps02">
<span class="captionLabel">Erste Schritte: </span>
<span class="caption">Konto mit Dateiimport anlegen</span><img src="/static/v3458/images/external/video/steps02s.png"/>
</a>
</li><li name="tour01" id="tour01">
<a href="#tour01">
<span class="captionLabel">Tour: </span>
<span class="caption">Umsätze bearbeiten und Finanzstatus</span>
<img src="/static/v3458/images/external/video/tour01s.png"/></a>
</li>
<li name="tour02" id="tour02">
<a href="#tour02">
<span class="captionLabel">Tour: </span>
<span class="caption">Finanzen analysieren und verstehen</span>
<img src="/static/v3458/images/external/video/tour02s.png"/>
</a>
</li>
</ul>

SS always deletes the ids of the ul and the li tags ?

How could I fix this problem ?

Thanks a lot...

Avatar
Herries

Community Member, 12 Posts

9 August 2010 at 4:32am

I also got the "Error Saving Content" message after installing the Image Gallery Module and trying to save the contents of a Image Gallery Page. I solved this by clicking 'Save' and then 'Save and Publish'.

If I clicked 'Save and Publish' first, it gave me the error. Weird!

Anyway, even though that seems like a weird solution, hope it helps someone.