Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

With the right links now: Different results in FF and IE - SWF and Colorbox on the site


Reply


1010 Views

Avatar
Spacepix

Community Member, 1 Post

31 October 2009 at 9:36am

Edited: 10/11/2009 10:21pm

With updated links now:

Hi Folks!

I would like to use some flash objects and a lightbox alternative, for example colorbox for my site. I use SS 2.3.3.
The common problem is, that flash objects are normally over the lightbox, so I normally have to set wmode=transparent by the flash object.

But with Silverstripe it's a little different:
It's working fine in Firefox without wmode=transparent, but not in IE and G-Chrome.
If I set wmode=transparent, it works fine with IE, but the flash doesn't work more in FF3.
What can be the reason for this?
Should I embed the SWF in a different way? I embedded the SWFs normally with the Tiny mce in this way: "<object width="180" height="325" data="assets/Uploads/almenu-iroda-berelheto-zsoltudvar-gale.swf" type="application/x-shockwave-flash"><param name="src" value="assets/Uploads/almenu-iroda-berelheto-zsoltudvar-gale.swf" /></object>"
or
"<object width="180" height="325" data="assets/Uploads/almenu-iroda-berelheto-zsoltudvar-gale.swf" type="application/x-shockwave-flash"><param name="wmode" value="transparent" /><param name="src" value="assets/Uploads/almenu-iroda-berelheto-zsoltudvar-gale.swf" /></object>"

Example for without wmode setting (it's working fine with FF3, but not with IE):
xxx

Example for wmode=transparent setting (it's working fine with IE, but the SWF is damaged in FF):
xxx

Thank you for your help!