Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Saving a URL in the CMS


Reply

3 Posts   715 Views

Avatar
Terry Apodaca

3 November 2009 at 11:36am Community Member, 109 Posts

How come i can't get any form fields in the backend (cms) to save a URL? Is there code in the CMS that is stopping this for some reason?

I made a custom template for a client, they want to play both video and audio, but they have both hosted some place else. I was just simply going to allow them to add the URL to a field in the cms, and then use the custom template to place the url in the < a href="$vidURL" and so on...but I can't save either version of this:

http://www.vimeo.com/82828282

www.vimeo.com/82828282

Every time it even says the field was saved fine...when you refresh it comes back blank.

Avatar
Mo

3 November 2009 at 12:00pm Community Member, 509 Posts

Sounds like there may be an error in how something is written. I have done this loads of times, without issue. Can you post your Model class (the one that extends page or sitetree) so we can have a gander?

Cheers,

Mo

Avatar
Terry Apodaca

4 November 2009 at 6:45am Community Member, 109 Posts

You were right...i had a misspelled variable in my php!!!.