Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

HTML button issues


Reply

6 Posts   1762 Views

Avatar
mattisimo

18 November 2009 at 2:12am Community Member, 9 Posts

Hi, when I click the HTML mode button on the editor on a new install, and on the online demo I get the following errors and the HTML mode editor is not initialised. Screenshot attached of popup.

Firefox error console:

Error: illegal character
Source File: http://demo.silverstripe.com/jsparty/tiny_mce2/tiny_mce_popup.js
Line: 1, Column: 6
Source Code:
GIF89a

Error: tinyMCEPopup is not defined
Source File: http://demo.silverstripe.com/jsparty/tinymce_advcode/js/dialog.js
Line: 1

Any suggestions? I assume it isn't an issue with my install as the same happens on the online demo.

Many thanks,

Matt

Attached Files
Avatar
banal

18 November 2009 at 2:48am Community Member, 901 Posts

Well it looks like you're getting a GIF image delivered instead of the JavaScript file. I'd say the problem lies on your end. Maybe it's a Firefox extension that messes things up?
Did you try another browser too? Which version of Firefox are you using?

Avatar
mattisimo

18 November 2009 at 3:02am Community Member, 9 Posts

Thanks for the reply Banal, I'm using FF 3.5.5.

I've also tried it in IE8, Safari and Chrome with the same outcome. I only have add-ons for FF (firebug, web dev toolbar).

IE8 error msg below:

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.0; Trident/4.0; GTB6; SLCC1; .NET CLR 2.0.50727; .NET CLR 1.1.4322; InfoPath.2; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
Timestamp: Tue, 17 Nov 2009 14:00:30 UTC

Message: 'tinyMCEPopup' is undefined
Line: 1
Char: 1
Code: 0
URI: http://demo.silverstripe.com/jsparty/tinymce_advcode/js/dialog.js

Thanks for your help

Avatar
banal

18 November 2009 at 4:54am Community Member, 901 Posts

That's really strange. Demo Site works here (FF 3.5.5 Mac OS X)
Maybe also check from another computer (if possible)?

Avatar
mattisimo

18 November 2009 at 5:00am Community Member, 9 Posts

That's made me think...

I just paused my Kaspersky security suite protection and it works fine!

Very strange and a little annoying as I don't really want to have to deactivate my AV to use the HTML mode. I'll have to do some digging into the settings.

Thanks for taking the time to help

Avatar
mattisimo

18 November 2009 at 5:14am Community Member, 9 Posts

In case anyone else is using Kaspersky Internet Security and runs into this issue, I've tracked down a solution on the TinyMCE support forum:

http://tinymce.moxiecode.com/punbb/viewtopic.php?id=18678

Cheers,

Matt