Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

General Questions /

General questions about getting started with SilverStripe that don't fit in any of the categories above.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Cannot access admin area - "Page not found" [RESOLVED]


Go to End
Reply


16 Posts   6119 Views

Avatar
katja

Community Member, 46 Posts

21 November 2009 at 11:10am

I have actually done 777 on the tmp directory, it did let me do that. There are also cached files in that directory, only they are directly under that dir, not in sub-directories. Does that matter? It is a reseller account, and I have other accounts with Silverstripe on it where everything works fine. This site used to work as well.. Not sure what I have done.

I do have a support chat with my host, but if I can do 777 on the tmp directory then I should have write access, shouldn't I?

Thanks again
Kat

Avatar
dalesaurus

Community Member, 283 Posts

21 November 2009 at 11:17am

Yes, you should. Have you tried making it recursive, chmod -R 777 /tmp/*

It is very strange that other SS installs beside it are working correctly. Perhaps one of these specific subdirs got chowned by some other user? You could always wipe out all related dirs/files in /tmp/ and see if SS can happily regenerate them with a /dev/build/?flush=all

Avatar
katja

Community Member, 46 Posts

21 November 2009 at 11:59am

Edited: 21/11/2009 12:01pm

Yeah, I did the recursive 777 when you first suggested the chmod, and I have also cleared all the cache. Didn't help. I wonder if for some reason on that host the user is not allowed to create a subfolder? It was slightly wrong what I wrote in my previous post, the cache files are under tmp/analog. Other tmp subdir.s are awstats, webalizer etc.. But in no Silverstripe installation do I get a subdir silverstripe-cache.. Maybe that is the crucial thing.

Interestingly, the warning has now changed to [Warning] fopen(/tmp/silverstripe-cache-home-henning-public_html/manifestClassParse-_home_henning_public_html_cms_code_CMSActionOptionsForm.php) [function.fopen]: failed to open stream: Permission denied

So am I right in thinking that in a "normal" SilverStripe installation a directory tmp/silverstripe-cache-home-etc. should get created?

In any case I can understand much better where the problem must be coming from..

Avatar
dalesaurus

Community Member, 283 Posts

21 November 2009 at 12:12pm

That part about the user being unable to create a dir is correct, and is very weird if you've wiped everything. Usually a recursive chmod 777 fixed that all up.

As you can see it create the cache systematically like
{TEMP_DIR}/silverstripe-cache{path to SilversStripe root, dashed out}/{File Path/Name Being Cached, dashed out}

That is all created on the fly if it doesn't already exist. It shouldn't need to be manually prodded like this. The root of this problem still hasn't been remedied, allowing your web user rwx access to the entire /tmp/ dir.

Its down to file system ownership and permissions now. I'm at a bit of a loss if you're wiped the tmp dir and done a chmod -R 777 on it. Do you have your Vhosts or apache user running under multiple usernames? I'm not sure that is even possible.

(Fake Edit: It really is! http://blog.andreaolivato.net/open-source/running-apache2-virtualhost-with-different-users.html )

Avatar
katja

Community Member, 46 Posts

21 November 2009 at 12:31pm

I have sent the host a message now as support chat was off. I am curiuous what they will say.

I am pretty sure I don't have Vhosts or apache user with multiple usernames. I definitely didn't tell them, I don't know anything about this, and would they have a reason to do that?

Anyway, will see what they say now. Thanks again for pointing me in the right direction.

Avatar
katja

Community Member, 46 Posts

22 November 2009 at 12:10pm

Hi,

did chat to my host now, and they fixed it, after I pointed out to them it could have to do with ownership of tmp folders/files.

You were spot on. After they fixed it, I asked what they did and the reply was: corrected the ownership of the folder /tmp/silverstripe-cache-home-henning-public_html . The ownership had been with a user id that had no user under it. Very weird. No idea, how this could have happened, but main thing is it works! I still cannot see the folder in question, but I suppose it must be there.

Thanks again, really glad this could be solved
Kat

Avatar
web2works

Community Member, 50 Posts

17 October 2010 at 4:22am

I had the same problem although it was due to mod_rewrite no being enable din my httpd.conf file.

Avatar
Naren

Community Member, 21 Posts

23 September 2013 at 10:32pm

Dear All,

I am having the same issue.

Previously I was having my site on www.mydomain.com/silverstripe and I was able to easily access the url www.mydomain.com/silverstripe/admin, but when i move it to www.mydomain.com. I am not able to access www.mydomain.com/admin

Please let me know how to fix that.

Thanks in advance

Go to Top