Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Hosting Requirements /

What you need to consider when choosing a hosting provider and plan.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Rewrite Htaccess


Reply


8 Posts   2160 Views

Avatar
Isacc13

Community Member, 7 Posts

13 October 2010 at 4:56pm

I've been having issues getting mod_rewrite to work properly with silverstripe on my website.
I have checked with my hosting service provider and they've told me that rewrite should work fine, I just need to update my htaccess file correctly.

So can anyone help me with what requirements or modifications I need to make to my htaccess file to make it work?

Avatar
Sean

Forum Moderator, 922 Posts

13 October 2010 at 5:33pm

Edited: 13/10/2010 5:35pm

You'll need to provide some more detail on your web server setup on the host before we can provide any more information.
If you're using Apache, you might want to check that "AllowOverride All" is set. If this has been disabled by the host, SilverStripe will not work with rewrites.

Sean

Avatar
Isacc13

Community Member, 7 Posts

13 October 2010 at 6:18pm

I'm using Justhost...so I don't really know more than that.

Avatar
Sean

Forum Moderator, 922 Posts

13 October 2010 at 6:53pm

Edited: 13/10/2010 6:54pm

Assuming the SS 2.4 installer is giving you a warning about not having rewrite support, have you tried to continue with the install anyway?

Avatar
Isacc13

Community Member, 7 Posts

14 October 2010 at 11:18am

Yeah, that's what I did. Installation worked, but now I am having some issues with the pages, and when seeking help I was told it related to my rewriting/htaccess.

For example, I cannot dev build using myurl.com/dev/build/?flush=1
I have to use myurl.com/index.php/...etc
If I try the first, I get a generic 404 error, not even the 404 error page I designed in Silverstripe.
I was told that both of these are an issue with my rewriting.

Avatar
mahir

Community Member, 11 Posts

10 February 2012 at 8:58am

I have the same problem with JustHost. They are using Apache. Here is the content of my htaccess.txt file

##
# @version      $Id: htaccess.txt 21101 2011-04-07 15:47:33Z dextercowley $
# @package      Joomla
# @copyright   Copyright (C) 2005 - 2011 Open Source Matters. All rights reserved.
# @license      GNU General Public License version 2 or later; see LICENSE.txt
##

##
# READ THIS COMPLETELY IF YOU CHOOSE TO USE THIS FILE!
#
# The line just below this section: 'Options +FollowSymLinks' may cause problems
# with some server configurations. It is required for use of mod_rewrite, but may already
# be set by your server administrator in a way that dissallows changing it in
# your .htaccess file. If using it causes your server to error out, comment it out (add # to
# beginning of line), reload your site in your browser and test your sef url's. If they work,
# it has been set by your server administrator and you do not need it set here.
##

## Can be commented out if causes errors, see notes above.
Options +FollowSymLinks

## Mod_rewrite in use.

RewriteEngine On
RewriteOptions Inherit

## Begin - Rewrite rules to block out some common exploits.
# If you experience problems on your site block out the operations listed below
# This attempts to block the most common type of exploit `attempts` to Joomla!
#
# Block out any script trying to base64_encode data within the URL.
RewriteCond %{QUERY_STRING} base64_encode[^(]*\([^)]*\) [OR]
# Block out any script that includes a <script> tag in URL.
RewriteCond %{QUERY_STRING} (<|%3C)([^s]*s)+cript.*(>|%3E) [NC,OR]
# Block out any script trying to set a PHP GLOBALS variable via URL.
RewriteCond %{QUERY_STRING} GLOBALS(=|\[|\%[0-9A-Z]{0,2}) [OR]
# Block out any script trying to modify a _REQUEST variable via URL.
RewriteCond %{QUERY_STRING} _REQUEST(=|\[|\%[0-9A-Z]{0,2})
# Return 403 Forbidden header and show the content of the root homepage
RewriteRule .* index.php [F]
#
## End - Rewrite rules to block out some common exploits.

## Begin - Custom redirects
#
# If you need to redirect some pages, or set a canonical non-www to
# www redirect (or vice versa), place that code here. Ensure those
# redirects use the correct RewriteRule syntax and the [R=301,L] flags.
#
## End - Custom redirects

##
# Uncomment following line if your webserver's URL
# is not directly related to physical file paths.
# Update Your Joomla! Directory (just / for root).
##

# RewriteBase /

## Begin - Joomla! core SEF Section.
#
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
#
# If the requested path and file is not /index.php and the request
# has not already been internally rewritten to the index.php script
RewriteCond %{REQUEST_URI} !^/index\.php
# and the request is for something within the component folder,
# or for the site root, or for an extensionless URL, or the
# requested URL ends with one of the listed extensions
RewriteCond %{REQUEST_URI} /component/|(/[^.]*|\.(php|html?|feed|pdf|vcf|raw))$ [NC]
# and the requested path and file doesn't directly match a physical file
RewriteCond %{REQUEST_FILENAME} !-f
# and the requested path and file doesn't directly match a physical folder
RewriteCond %{REQUEST_FILENAME} !-d
# internally rewrite the request to the index.php script
RewriteRule .* index.php [L]
#
## End - Joomla! core SEF Section.

I dont want to have an index.php, on my URL. Any help will be appreciated.

Avatar
Lexandclo

Community Member, 34 Posts

13 February 2012 at 12:12am

Hi

is joomla installed IN the same dir as silverstripe?

try adding this in .htacces

RewriteBase \ ( if ss in public_html remove all this, or write name of dir its in)

like
in public_html
RewriteBase \

in sub dir called newsite
RewriteBase \newsite

let me know if this helps

Darren

Avatar
mahir

Community Member, 11 Posts

13 February 2012 at 1:13am

Edited: 13/02/2012 2:22am

Hi Turnaound Guy,
Thank you for your reply.

It works fine now :)