Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Hosting Requirements

What you need to consider when choosing a hosting provider and plan.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

[3.0] SilverStripe cache preventing site from loading


2 Posts   556 Views


11 October 2013 at 10:24pm (Last edited: 11 October 2013 10:25pm), Community Member, 44 Posts

I'm hosting SS 3.0.8 on a linux server with the setup detailed below. Every now and then (couple of times per hour) I'm unable to access anything on the ADMIN section to an Uncaught Zend_Locale_exception.

The frontend site is still ok. ?flush=all has no effect. The only temporary fix is for me to run the following command:

$ sudo rm -rf /tmp/silverstripe-cache* && sudo apache2ctl restart

Because this only works after restarting apache it looks like the process is locking a file, but I have no idea what's going on. My production server doesn't exhibit this problem.

Any help would be most welcome.

Linux Ubuntu Server box (12.04.3 - up to date)

$ apache2ctl -v
/usr/sbin/apache2ctl: 87: ulimit: error setting limit (Operation not permitted)
Server version: Apache/2.2.22 (Ubuntu)
Server built: Jul 12 2013 13:37:10

php -v
PHP 5.3.10-1ubuntu3.8 with Suhosin-Patch (cli) (built: Sep 4 2013 20:00:51)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.3.0, Copyright (c) 1998-2012 Zend Technologies
with Xdebug v2.1.0, Copyright (c) 2002-2010, by Derick Rethans
with Suhosin v0.9.33, Copyright (c) 2007-2012, by SektionEins GmbH

$ mysql --version
mysql Ver 14.14 Distrib 5.5.32, for debian-linux-gnu (x86_64) using readline 6.2

caching related mysite/_config.php:
DateField::set_default_config('showcalendar', true);
if (Director::isDev()) {
SS_Cache::set_cache_lifetime('any', -1, 100);


18 October 2013 at 3:33pm Community Member, 254 Posts

Hmmmm thats a tough one.

Sometimes SS spits out misleading error messages. Perhaps check the php error log for any clarification.