Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Hosting Requirements /

What you need to consider when choosing a hosting provider and plan.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba

SS3.1 OEMBED on MediaTempl DV4 (nginx)


Go to End
Reply


4 Posts   714 Views

Avatar
zenmonkey

Community Member, 541 Posts

26 April 2014 at 6:46am

I'm having issue using oembed on Media Temple DV4, I'm assuming its a NGINX issue right now. After some digging into the included oemebd code, I noticed that when you use the short code embed from youtube or vimeo the server doesn't follow the 301 rederiect of the shortner. The server queries youtube, and interprests teh response as an okay and doesn't follow it through.

It's not heppening locally, just wondering what settings need to change on the server.

Avatar
camfindlay

Forum Moderator, 221 Posts

27 July 2014 at 8:16pm

Interesting, I'm running my site on Nginx but actually haven't tested the Oembed stuff... I might do so and see if mine works... if it does I'll post my nginx conf settings - if not it will be interesting to work out the issue.

Avatar
micschk

Community Member, 20 Posts

11 February 2015 at 9:27pm

Edited: 11/02/2015 9:28pm

For people stumbling onto this thread; we've run into similar problems with Curl on Apache not following 301 redirects. Here it was caused by open_basedir being set or misconfigured. On Apache, open_basedir needs to be set to none in php.ini for Curl to follow 301s. Maybe a similar config needs to be set on Nginx?

ERROR: "CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set"

Avatar
atari

Community Member, 1 Post

20 February 2015 at 10:12pm

Yep, confirming zenmonkey's solution, ran into this yesterday on my DV4.
I was getting an imagecreatefromjpeg warning and oembed elements were just appearing as links.

DV4 solution
Go into: <whichever domain> -> General -> Customize -> PHP Settings
Look for: open_basedir
Set to: none

Thx ZM :)