Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Friendly URLs are not working


Reply

7 Posts   3408 Views

Avatar
wizzofoz

24 November 2009 at 9:09am (Last edited: 24 November 2009 9:26am), Community Member, 9 Posts

After starting Silverstripe the first time I get the configuration page (install.php).
When I submit this page after a few seconds I see the following message:

Checking that friendly URLs work...
Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
mod_rewrite is enabled
AllowOverride All is set for your directory

Extra info: installed on Windows 2003 Server / IIS 6 / PHP / FastCGI / ISAPIRewrite (free version)

Avatar
Sean

24 November 2009 at 9:12pm Forum Moderator, 921 Posts

The installer won't detect you're using a third-party URL rewriting module.

Once this message occurs, are you able to browse to the installed SS copy and see if it works anyway?

http://localhost/silverstripe/dev/build?flush=all

Sean

Avatar
wizzofoz

25 November 2009 at 6:48am (Last edited: 25 November 2009 6:53am), Community Member, 9 Posts

No Sean, I cannot access that page (Page Not Found)

I can run rewritetest.php but this gives the following message:

mod_rewrite doesn't appear to be working. Make sure:
mod_rewrite is enabled in your httpd.conf
AllowOverride is enabled for the current path.

Avatar
wee-man

25 November 2009 at 10:10pm Community Member, 21 Posts

Hello,

by default Silverstripe uses the .htaccess to define rewrite rules.
But this is only working automatically with the Apache webserver.

You have to define the rewrite rules for your rewrite engine by hand.
For that have a look in the ISAPIRewrite documentation.

Your can find the required rewrite rules in your Silverstripe root directory in the .htaccess file.

Greetings

Avatar
Sean

25 November 2009 at 10:12pm (Last edited: 25 November 2009 10:15pm), Forum Moderator, 921 Posts

The only thing I can think of is that your rewrite module isn't working properly.

There's a part in the installer that does an AJAX request to InstallerTest/testrewrite which is generic for any rewriting capability - so this means it'll work for the IIS 7 rewrite module, Apache mod_rewrite or ISAPIRewrite if it's setup correctly.

I'm not too familiar with ISAPIRewrite and installing SS on IIS 6, as I've only installed and used SS on IIS 7 and IIS 7.5.
I assume ISAPIRewrite uses some form of .htaccess file for configuration?

EDIT: Just came across this URL, might be of some help: [url]http://cubiksoundz.blogspot.com/2008/12/tech-note-installing-silverstripe-cms.html[/url]

Sean

Avatar
wizzofoz

26 November 2009 at 8:35am Community Member, 9 Posts

Well ... I've found the solution.

Forget about IIS and install WAMP, up and running within 5 minutes :-)

Avatar
Sean

26 November 2009 at 9:20am Forum Moderator, 921 Posts

That's one way - IIS 7 with the MS URL rewriting module appears to work pretty well. However, that requires at least Windows Server 2008 I believe.

Sean