Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

installation problems windows XP


Reply


3 Posts   2111 Views

Avatar
wiboc

Community Member, 1 Post

4 December 2009 at 1:22am

Hello,

tried to start with SS. Installing on a windows XP doesn't work. Wampp is correct installed.
The latest version of SS installed gives the following messages:

Deprecated: Function ereg_replace() is deprecated in D:\wamp\www\SilverStripe\install.php on line 305
Installing SilverStripe...

I am now running through the installation steps (this should take about 30 seconds)

If you receive a fatal error, refresh this page to continue the installation
# Creating 'mysite/_config.php'...
# Creating D:\wamp\www\SilverStripe/mysite/_config.php
# Creating '.htaccess' file...
# Creating D:\wamp\www\SilverStripe/.htaccess
# Building database schema...

Deprecated: Function ereg_replace() is deprecated in D:\wamp\www\SilverStripe\sapphire\core\ManifestBuilder.php on line 91

Deprecated: Function ereg_replace() is deprecated in D:\wamp\www\SilverStripe\sapphire\core\ManifestBuilder.php on line 237

Deprecated: Assigning the return value of new by reference is deprecated in D:\wamp\www\SilverStripe\auth_openid\code\Auth\OpenID\Consumer.php on line 270

Deprecated: Assigning the return value of new by reference is deprecated in D:\wamp\www\SilverStripe\auth_openid\code\Auth\OpenID\Consumer.php on line 272

someone knows what the problem is???

Avatar
Willr

Forum Moderator, 5513 Posts

4 December 2009 at 9:49am

These are just warnings, the script should have installed correctly. Its an issue with running PHP5.3. SS2.3.4 and the 2.4 release should have removed these warning messages. If you're trying to use 2.3.3 then try 2.3.4 (I think the warnings have been removed from that). Otherwise you could set the error_reporting() in your mysite/_config.php to hide deprecated warnings

error_reporting(E_ALL ^ E_DEPRECATED);

Avatar
Sean

Forum Moderator, 922 Posts

4 December 2009 at 9:52am

Probably best to edit the error_reporting level inside php.ini instead of the SS code, otherwise you'll have to change the reporting level each time.

Look for error_reporting = E_ALL | E_STRICT and change it to error_reporting = E_ALL ^ E_DEPRECATED

Sean