Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

PHP Error


Reply


2 Posts   988 Views

Avatar
Secura

Community Member, 1 Post

9 December 2009 at 12:12am

Edited: 09/12/2009 8:01am

I am trying to install SilverStripe on a webserver, but i get this PHP Error, i'm new to CMS's and fairly new to PHP too, so i'm hoping i can get some help here, thanks!

Edit - i am having some issues putting AllowOverride All into my .htaccess file, it keeps giving me an internal server error, is anyone able to help?

What the webserver is running:
Apache ver.    2.2.13 (Unix)
PHP version    5.2.*
MySQL ver.    5.0.81-community

* Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
o AllowOverride All is set for your directory

Avatar
OwenW

Community Member, 45 Posts

10 December 2009 at 5:59pm

Hi Secura,

Do you manage the server yourself, or is it a shared host?

Basically what I would be looking at here is that the default installation of Apache on most linux's now has a fantastic little security modification that prevents .htaccess from getting executed correctly.

First up, AllowOverride is a directive that can only go in the main httpd.conf or within a vhost container.

AllowOverride's function is to tell apache that .htaccess files are permitted to override the base server config.

So in your scenario (assuming you manage your own server), Have a look in the apache configuration file for a code block similar to this..

<Directory />
Options FollowSymLinks
AllowOverride None
</Directory>

This is saying that the AllowOverride function for the root path is disallowed, and will prevent you from being able to execute the required .htaccess. (This is now the default for apache 2.2 installs and maybe earlier - can't quite recall)

Make a change to that code block, to allow the override, then restart apache. Test the Silverstripe install again, and it should be OK.

Hopefully this will get you on your way.

Cheers
Owen