Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

2.4 Alpha *requires* PHP >= 5.2


Reply


6 Posts   1200 Views

Avatar
geoffmcqueen

Community Member, 11 Posts

6 January 2010 at 7:03pm

Hi dev team,

During the installation process for SS alpha 2.4, it is mentioned that PHP 5.2 or greater is recommended for this new version.

I just wanted to let you know that it *appears* (not a PHP expert here) that it is actually mandatory. Basically, the new version can't create the database tables, which makes it all kinda broken.

The specific error under PHP 5.1.6 in the Apache logs is: "PHP Fatal error: Call to undefined function array_fill_keys() in /xxxx/sapphire/core/Object.php on line 678"

I'm not sure whether array_fill_keys() can be created as a user defined function without doing the 5.2 upgrade, or whether instead the instructions for installing the Alpha should be that you *need* to have 5.2. I'm running RHEL 5 and getting PHP 5.2 is quite a pain if you want to keep running with yum and packages, so it would be ideal if PHP 5.2 wasn't a requirement...

Geoff

Avatar
Willr

Forum Moderator, 5513 Posts

6 January 2010 at 8:48pm

A developer here has done some work to fix the array_fill_keys issue on a project branch. We will be getting the fixes from that to branches/2.4 as soon as possible for a 2.4 release. If we officially drop 5.1 support (which we won't for the foreseeable future since LTS versions + RHEL will be on 5.1 for a while yet) we will make sure this change is communicated.

Avatar
geoffmcqueen

Community Member, 11 Posts

7 January 2010 at 12:57pm

Thanks for that Will - I think it will make system dependencies much easier to keep on top of.

One other dependency that 2.4 seemed to have introduced that the current stable version needed is related to the DOMDocument. I had to install php-xml (I think - I'm not a PHP expert and I actually installed a few others at the same time, including php-devel and php-tidy, but I think php-xml was the one I needed) to get the 2.4 version to work.

The additional package isn't as big a deal as needing the (from a package perspective, still experimental) 5.2 version, but I thought it might be handy to mention that too in case the DOMDocument calls aren't really necessary.

Avatar
geoffmcqueen

Community Member, 11 Posts

7 January 2010 at 1:00pm

Oh, and again, a bit of a noob question: how can I be kept up to date when the change from the project branch is rolled into the 2.4 branch?

Avatar
Willr

Forum Moderator, 5513 Posts

7 January 2010 at 4:24pm

Normally information relating to releases and development of modules / branches is posted to the google groups

http://groups.google.com/group/silverstripe-announce
http://groups.google.com/group/silverstripe-dev

Avatar
geoffmcqueen

Community Member, 11 Posts

7 January 2010 at 4:39pm

Thanks for that - have joined one and applied to join the other... ;-)