Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

After install moving SS from root to a subfolder ?


Reply


2 Posts   2244 Views

Avatar
teejay

Community Member, 63 Posts

17 February 2010 at 12:34pm

Edited: 17/02/2010 1:07pm

Hello, I tried this morning to move my local SS installation to a pseudo staging env on a live server. I installed ss for a root installation. Now I need to move it in a sub folder to simulate a staging site. I cant create a subdomain because the hoster doesnt want to offer this service without charging me 350 dollars (retarded!). So my ideas was, why not moving it in sub folder under the root -> like domain.com/staging/

What I have done is I changed the htaccess

RewriteBase /staging/

then I changed the mysite/_config.php

Director::setBaseURL("http://domain.com.au/staging/");

that should do the trick and works so far for the normal website perfect. But when i want to access the admin the login form wont direct me to the cms. It ends up again and again on the login page without any error or validation error. Does anyone has an idea what I need to do to get the cms working ?

THX in advance Thomas

edit:

dont put setBaseURL in the _config, just change the htaccess and it works like charm :) (Fixed)

Avatar
Sean

Forum Moderator, 922 Posts

26 February 2010 at 12:20am

Good to see you got it sorted!

Sean