Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

Install - Nothing Happens


Reply

5 Posts   2055 Views

Avatar
brandstudionz

23 February 2010 at 4:51pm (Last edited: 23 February 2010 4:51pm), Community Member, 3 Posts

Hello,

I'm really hoping someone can't shed some light on this, it has happened to me a number of times in different environments.

Scenario
- ** FIRST TIME ROUND ** Install silverstripe works fine.
- Client crashes the system or you upload a new version from scratch / ie delete all files and database entries.
- Run Installer
- Enter database etc says all OK
- Click Install and it starts working for around 3 secs then simply stops and does nothing....

Here is other posts which appears to be the same issue.

http://www.silverstripe.org/installing-silverstripe/show/266470?start=0
http://www.silverstripe.org/archive/show/14220#post14220

What is causing it to fail when first time round it went without a hitch? What files could
be affecting it? ..even though it appears all files have been thoroughly removed.

PLEASE HELP!! :)

Thanks in advance - Sefton

Avatar
Sean

26 February 2010 at 12:03am (Last edited: 26 February 2010 12:05am), Forum Moderator, 921 Posts

SilverStripe stores a bunch of temporary files inside temp directories in the filesystem. These are typically at /tmp or /var/tmp if Linux or Mac OS X. On Windows, it's C:\Windows\Temp.

You might want to try adding a new empty directory inside your SilverStripe project called "silverstripe-cache", it will need writable permissions by the webserver as well. If SilverStripe detects this directory, it will take preference of it over the system temporary directories. The advantage is it's easier to clear out the temporary files if you reinstall, since it's in the same place where SilverStripe is installed.

When you reinstall, you can just replace the silverstripe-cache directory with a empty one and all the cached SS files from the old installation will be gone.

Cheers,
Sean

Avatar
eddy

26 February 2010 at 8:45am (Last edited: 28 February 2010 1:59pm), Community Member, 1 Post

Hi,
I also need some help in this regard...
SS Version 2.3.6
Suse11
Apache 2
PHP 5.2.9
MYSQL 5.0.6

SS starts to install until it hangs without apparent reason.
The only hint that something went wrong, is in the Firefox tab where it says "PHP 5 required". Well, I do have PHP 5 on my server and all folders that need to be set writable have their correct rights. No table has been created in the database although the database itself has been created.

Any ideas?

I attached a screenshot for FYI...
TIA,
Erhard

Edit:
Just tried the trick with the cach-folder inside the silverstripe folder and re-started the installation. Same result as before and the cache folder is empty.

2. edit (2010-02-28):
Well, I vaguely hoped for a reply from the developers of SS... Given the fact that Germany (time-wise) is well behind NZ, I should think that this not asked too much. Guess, I drop SS and go back to good old typo3. Bye.

Attached Files
Avatar
phawley

2 March 2010 at 8:34am (Last edited: 2 March 2010 8:34am), Community Member, 21 Posts

Hey there. I was having the same problem, and if you tail your logs, you should find the answer (or at the very least some really good clues). I had old cache issues, and so once I created the new cache folder inside of my SS installation, I still had the same white screen.

Checking the php_error.log (I am running MAMP on OSX, so its full path is /Applications/MAMP/logs/php_error.log) with the tail command showed file permission probs. I changed the permissions to 777 and was good to go.

I'm not super keen on running a folder with 777 permissions, so I'll tinker/fine tune with permissions and ownership, etc. now, but I was happy to see that the upgrade worked, dev site runs once again, and I now have Nested URLs enabled!!!!!! ;)

HTH,
Patrick

Avatar
stx333

14 March 2010 at 7:17am Community Member, 14 Posts

Are you not forgetting to input an admin password, or other details BELOW the database section?

This helped in my case.

The thing is no error/warning/hint is displayed in the case above...

Hope this helps!