Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe /

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

"Friendly URLs are not working." at installation process


Reply


2 Posts   1520 Views

Avatar
dizzy_fingers

Community Member, 2 Posts

24 February 2010 at 9:01am

Hello people,

I tried to install silverstripe 2.3.6 on my server but the installation process stopped at the "Friendly URLs are not working." message:

  • Creating 'mysite/_config.php'...
  • Creating /home/dentalclinic/htdocs/mysite/_config.php
  • Creating '.htaccess' file...
  • Creating /home/dentalclinic/htdocs/.htaccess
  • Building database schema...
  • Checking that friendly URLs work...
  • Friendly URLs are not working. This is most likely because mod_rewrite isn't configuredcorrectly on your site. Please check the following things in your Apache configuration; you may need to get your web host or server administrator to do this for you:
    • mod_rewrite is enabled
    • AllowOverride All is set for your directory

- mod_rewrite is enabled. The specific line in the installation page was highlighted green.
- AllowOverride All is also set for the site's directory in apache.

So what else could be wrong?

Thank you in advance.

Avatar
dizzy_fingers

Community Member, 2 Posts

24 February 2010 at 9:45am

An update to my attempts to bypass the errors:

- Tried to do what is listed here http://stackoverflow.com/questions/1768300/friendly-urls-not-working-modrewrite-enabled-what-gives but I found from that is that AllowOverride All indeed exists, as a "fdfssfsfds" line in the .htaccess created a 500 error.
- Also the mod_rewrite works since I don't get an error when I go to the http://www.site.com/about-us/ page and the data is shown OK, except for the .css, .js and images. The url of the .css file, for example, is http://www.site.com/index.php/themes/tutorial/css/layout.css?m=1266957292. If I remove this "index.php" string, the css is loaded.