Skip to main content

This site requires you to update your browser. Your browsing experience maybe affected by not having the most up to date version.

Installing SilverStripe

Getting SilverStripe up and running on your computer and on your web server.

Moderators: martimiz, Sean, biapar, Willr, Ingo, swaiba, simon_w

I thought I was an intelligent guy.....


Reply

4 Posts   1149 Views

Avatar
tonyk11

5 March 2010 at 4:47pm Community Member, 3 Posts

....but I'm obviously lacking somewhere. I've tried to install SS about 3 times now, twice with the online windows installer and once from the stable download. I've placed the files in a local folder I use for websites that I'm developing, and I've installed MySql along with Microsoft SQL Server 2008, IIS, and Apache (just for my experimental purposes). I still cannot access anything in the SS files, other than some code that comes up on a white screen when I click the index.php file. I can't seem to access any type of admin screen, or any type of editing GUI. The video that showed the capabilities of SS made me really want to work with this program (I can code a website, but this seems much faster and more convenient), but perhaps I've misunderstood how the interface is supposed to work. I'm picturing downloading this zip file, unzipping, clicking an installer or unpacking the files, and then clicking on a link that will take me to the interface where I can point SS toward the files I want to manipulate. But it doesn't seem that it works as such. Any help would be awesome. Think as though you're explaining it to a child.... That should help make sure I understand.

The video that was produced to show the capabilities of SS was really great. Maybe a video like that for the installation of SS would be a great addition to the site. If there is one, I didn't see it, so feel free to point me to it.

If I seem like a newb, I am....to CMS's. All help is appreciated..... Thanks.

Avatar
tonyk11

5 March 2010 at 8:43pm Community Member, 3 Posts

This is what I'm getting when I try to run the install....

$snLen && substr($_SERVER['REQUEST_URI'],0,$snLen+1) == ($_SERVER['SCRIPT_NAME'] . '/')) { $url = substr($_SERVER['REQUEST_URI'],$snLen+1); $url = strtok($url, '?'); } else { $url = $_SERVER['REQUEST_URI']; if($url[0] == '/') $url = substr($url,1); $url = strtok($url, '?'); } // Apache will populate the server variables this way } else { if($ruLen > $snLen && substr($_SERVER['REQUEST_URI'],0,$snLen+1) == ($_SERVER['SCRIPT_NAME'] . '/')) { $url = substr($_SERVER['REQUEST_URI'],$snLen+1); $url = strtok($url, '?'); } else { $url = ""; } } $_GET['url'] = $_REQUEST['url'] = $url; $fileName = dirname($_SERVER['SCRIPT_FILENAME']) . '/' . $url; /** * This code is a very simple wrapper for sending files * Very quickly pass through references to files */ if($url && file_exists($fileName)) { $fileURL = dirname($_SERVER['SCRIPT_NAME']) . '/' . $url; header($_SERVER['SERVER_PROTOCOL'] . ' 301 Moved Permanently'); header("Location: $fileURL"); die(); } // For linux $_SERVER['SCRIPT_FILENAME'] = str_replace('/index.php','/sapphire/main.php', $_SERVER['SCRIPT_FILENAME']); $_SERVER['SCRIPT_NAME'] = str_replace('/index.php','/sapphire/main.php', $_SERVER['SCRIPT_NAME']); // And for windows $_SERVER['SCRIPT_FILENAME'] = str_replace('\\index.php','\\sapphire\\main.php', $_SERVER['SCRIPT_FILENAME']); $_SERVER['SCRIPT_NAME'] = str_replace('\\index.php','\\sapphire\\main.php', $_SERVER['SCRIPT_NAME']); chdir('sapphire'); require_once('sapphire/main.php');

Any suggestions?

Avatar
Sean

7 March 2010 at 6:22pm (Last edited: 7 March 2010 6:23pm), Forum Moderator, 921 Posts

Have you tried using [url=http://www.microsoft.com/web/Downloads/platform.aspx]Microsoft Web Platform Installer[/url]?

Manually setting up IIS means you have to get into the IIS Manager and add a FastCGI entry for PHP yourself. A [url=http://learn.iis.net/page.aspx/246/using-fastcgi-to-host-php-applications-on-iis-70/]setting up PHP on IIS guide[/url] shows you how to do that.

But seriously, you'll want to use the Web Platform Installer, it does all the above for you.

Sean

Avatar
tonyk11

10 March 2010 at 5:51pm Community Member, 3 Posts

I've actually tried that route about 3 times. I still can't get anything to happen. I tried the installer at first, and then went to the package.

It would be great if there was a step-by-step for both ways to get this installed for different OS's. Anyway, I'm not sure why it won't work, but I'm positive it has to do with me and not the software. I'll keep trying, and if anyone else has any other advice, I'm all ears.

Tony